summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-08-26 19:02:46 +0100
committerSam James <sam@gentoo.org>2023-08-27 21:26:13 +0100
commitf0a16a3f519de9ec5ecef601788219dbba7e1a8f (patch)
treedee0ded9fd46805a6840710536122c1fbc48da57 /dev-libs/tree-sitter/tree-sitter-0.20.8-r1.ebuild
parenttree-sitter-grammar.eclass: force use of local parser.h (diff)
downloadgentoo-f0a16a3f519de9ec5ecef601788219dbba7e1a8f.tar.gz
gentoo-f0a16a3f519de9ec5ecef601788219dbba7e1a8f.tar.bz2
gentoo-f0a16a3f519de9ec5ecef601788219dbba7e1a8f.zip
dev-libs/tree-sitter: stop installing parser.h
There shouldn't be a system-wide copy of parser.h and upstream plan on dropping this from dev-libs/tree-sitter as it can cause issues if there's a mismatch between the version used for the bundled generated parser vs the header used to build the library. Backport that change to avoid mismatches. Bug: https://github.com/tree-sitter/tree-sitter-bash/issues/199 Bug: https://bugs.gentoo.org/912716 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/tree-sitter/tree-sitter-0.20.8-r1.ebuild')
-rw-r--r--dev-libs/tree-sitter/tree-sitter-0.20.8-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-libs/tree-sitter/tree-sitter-0.20.8-r1.ebuild b/dev-libs/tree-sitter/tree-sitter-0.20.8-r1.ebuild
new file mode 100644
index 000000000000..734e7a2a9491
--- /dev/null
+++ b/dev-libs/tree-sitter/tree-sitter-0.20.8-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit optfeature toolchain-funcs
+
+DESCRIPTION="Tree-sitter is a parser generator tool and an incremental parsing library"
+HOMEPAGE="https://github.com/tree-sitter/tree-sitter"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-No-static-libs-gentoo.patch"
+ "${FILESDIR}/${PN}-0.20.8-no-parser-header.patch"
+)
+
+# see Makefile:1
+QA_PKGCONFIG_VERSION="0.20.9"
+
+# XXX: Please, don't forget to check this on next version bump.
+# And, maybe remove as non-needed, if version in Makefile will
+# match the release.
+# ref: https://github.com/tree-sitter/tree-sitter/issues/2210
+
+src_prepare() {
+ default
+ tc-export CC
+}
+
+src_compile() {
+ emake \
+ PREFIX="${EPREFIX}/usr" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ PREFIX="${EPREFIX}/usr" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ install
+}
+
+pkg_postinst() {
+ optfeature "building and testing grammars" dev-util/tree-sitter-cli
+}