summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2022-08-03 19:05:16 -0700
committerIonen Wolkens <ionen@gentoo.org>2022-08-04 10:11:09 -0400
commita449b0be4556c0774529ec986ca15fc0d7a65d99 (patch)
treecdf63b6c02b361adc005e38757e0026227ff0a0d /dev-libs/trio/trio-1.17.ebuild
parentgames-engines/qtads: add 3.3.0 (diff)
downloadgentoo-a449b0be4556c0774529ec986ca15fc0d7a65d99.tar.gz
gentoo-a449b0be4556c0774529ec986ca15fc0d7a65d99.tar.bz2
gentoo-a449b0be4556c0774529ec986ca15fc0d7a65d99.zip
dev-libs/trio: Add 1.17
Closes: https://github.com/gentoo/gentoo/pull/26711 Signed-off-by: orbea <orbea@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/26734 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-libs/trio/trio-1.17.ebuild')
-rw-r--r--dev-libs/trio/trio-1.17.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-libs/trio/trio-1.17.ebuild b/dev-libs/trio/trio-1.17.ebuild
new file mode 100644
index 000000000000..cef261694cde
--- /dev/null
+++ b/dev-libs/trio/trio-1.17.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DOCS_BUILDER="doxygen"
+DOCS_DEPEND="media-gfx/imagemagick"
+DOCS_DIR="doc"
+
+inherit docs
+
+DESCRIPTION="Portable string functions, focus on the *printf() and *scanf() clones"
+HOMEPAGE="https://daniel.haxx.se/projects/trio/"
+SRC_URI="https://github.com/orbea/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="trio"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ default
+ docs_compile
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}