summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kołodziej <kacper@kolodziej.in>2017-03-11 12:34:59 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-06-03 23:26:22 +0200
commita1956cb78426714fd8f0fcc55b5a60e5390724b0 (patch)
tree2b3c8b9365b3907f945b3d343a73441543655d2e /dev-libs/tvision/tvision-2.1.0_pre2-r4.ebuild
parentdev-libs/tvision: Fix gcc-6 compilation errors (diff)
downloadgentoo-a1956cb78426714fd8f0fcc55b5a60e5390724b0.tar.gz
gentoo-a1956cb78426714fd8f0fcc55b5a60e5390724b0.tar.bz2
gentoo-a1956cb78426714fd8f0fcc55b5a60e5390724b0.zip
dev-libs/tvision: Bump to EAPI=6
Package-Manager: Portage-2.3.4, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/4182
Diffstat (limited to 'dev-libs/tvision/tvision-2.1.0_pre2-r4.ebuild')
-rw-r--r--dev-libs/tvision/tvision-2.1.0_pre2-r4.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-libs/tvision/tvision-2.1.0_pre2-r4.ebuild b/dev-libs/tvision/tvision-2.1.0_pre2-r4.ebuild
new file mode 100644
index 000000000000..3e21aab2f9e4
--- /dev/null
+++ b/dev-libs/tvision/tvision-2.1.0_pre2-r4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Text User Interface that implements the well known CUA widgets"
+HOMEPAGE="http://tvision.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tvision/rhtvision_${PV/_pre/-}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DOCS=( readme.txt THANKS TODO )
+
+HTML_DOCS=( www-site/. )
+
+S=${WORKDIR}/${PN}
+
+PATCHES=(
+ "${FILESDIR}/${P}-gcc41.patch"
+ "${FILESDIR}/${P}-outb.patch"
+ "${FILESDIR}/${P}-underflow.patch"
+ "${FILESDIR}/${P}-asneeded.patch"
+ "${FILESDIR}/${P}-gcc44.patch"
+ "${FILESDIR}/${P}-ldconfig.patch"
+ "${FILESDIR}/${P}-flags.patch"
+ "${FILESDIR}/${P}-gcc6.patch" # bug #594176
+ "${FILESDIR}/${P}-build-system.patch" # for EAPI=6
+)
+
+src_configure() {
+ ./configure --fhs || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install \
+ prefix="\${DESTDIR}/usr" \
+ libdir="\$(prefix)/$(get_libdir)"
+
+ einstalldocs
+ dosym rhtvision /usr/include/tvision
+}