summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/ucommon/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/ucommon/files')
-rw-r--r--dev-libs/ucommon/files/6.1/disable_rtf_gen_doxy.patch11
-rw-r--r--dev-libs/ucommon/files/6.1/gcrypt_autotools.patch58
-rw-r--r--dev-libs/ucommon/files/6.1/install_gcrypt.m4_file.patch128
-rw-r--r--dev-libs/ucommon/files/disable_rtf_gen_doxy.patch18
-rw-r--r--dev-libs/ucommon/files/gcrypt_autotools.patch62
-rw-r--r--dev-libs/ucommon/files/install_gcrypt.m4_file.patch128
-rw-r--r--dev-libs/ucommon/files/ucommon-5.2.2-address.patch42
-rw-r--r--dev-libs/ucommon/files/ucommon-6.3.1-gcrypt_autotools.patch48
8 files changed, 495 insertions, 0 deletions
diff --git a/dev-libs/ucommon/files/6.1/disable_rtf_gen_doxy.patch b/dev-libs/ucommon/files/6.1/disable_rtf_gen_doxy.patch
new file mode 100644
index 000000000000..1aaf478ed320
--- /dev/null
+++ b/dev-libs/ucommon/files/6.1/disable_rtf_gen_doxy.patch
@@ -0,0 +1,11 @@
+--- Doxyfile.orig 2014-06-26 23:56:45.724303475 +0300
++++ Doxyfile 2014-06-26 23:57:12.875021734 +0300
+@@ -40,7 +40,7 @@
+ GENERATE_HTMLHELP = YES
+ GENERATE_TREEVIEW = NO
+ TREEVIEW_WIDTH = 256
+-GENERATE_LATEX = YES
++GENERATE_LATEX = NO
+ COMPACT_LATEX = YES
+ PDF_HYPERLINKS = YES
+ USE_PDFLATEX = NO
diff --git a/dev-libs/ucommon/files/6.1/gcrypt_autotools.patch b/dev-libs/ucommon/files/6.1/gcrypt_autotools.patch
new file mode 100644
index 000000000000..2ec0858245d9
--- /dev/null
+++ b/dev-libs/ucommon/files/6.1/gcrypt_autotools.patch
@@ -0,0 +1,58 @@
+diff --git a/Makefile.am b/Makefile.am
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -8,6 +8,8 @@
+ # WITHOUT ANY WARRANTY, to the extent permitted by law; without even the
+ # implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
+
++ACLOCAL_AMFLAGS = -I m4
++
+ EXTRA_DIST = autogen.sh README* *.pc.in *.spec.in *.spec *-config.in \
+ *-config.1 Doxyfile cmodel.sh BUILDS SUPPORT COPYING* COPYRIGHT \
+ CMakeLists.txt ucommon-config.cmake ucommon.pc.cmake cmake-abi.sh \
+diff --git a/configure.ac b/configure.ac
+--- a/configure.ac
++++ b/configure.ac
+@@ -40,6 +40,9 @@
+
+ CHECKFLAGS="$CHECKFLAGS"
+
++m4_include([m4/libgcrypt.m4])
++
++
+ case "$with_crypto" in
+ ssl|openssl)
+ ssl="openssl"
+@@ -698,6 +701,8 @@
+ gnutls|gnu)
+ if test ! -z "$GNUTLS_LIBS" ; then
+ SECURE_LIBS="$GNUTLS_LIBS"
++ AM_PATH_LIBGCRYPT
++ SECURE_LIBS="$GNUTLS_LIBS $LIBGCRYPT_LIBS"
+ SECURE="gnutls"
+ fi
+ ;;
+diff --git a/utils/Makefile.am b/utils/Makefile.am
+--- a/utils/Makefile.am
++++ b/utils/Makefile.am
+@@ -9,9 +9,9 @@
+ # implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
+
+ MAINTAINERCLEANFILES = Makefile.in Makefile
+-AM_CXXFLAGS = -I$(top_srcdir)/inc @UCOMMON_FLAGS@
++AM_CXXFLAGS = -I$(top_srcdir)/inc @UCOMMON_FLAGS@ @LIBGCRYPT_CFLAGS@
+ AM_CPPFLAGS = -I$(top_srcdir)/inc
+-LDADD = ../corelib/libucommon.la @UCOMMON_LIBS@ @UCOMMON_CLINK@
++LDADD = ../corelib/libucommon.la @UCOMMON_LIBS@ @UCOMMON_CLINK@ @LIBGCRYPT_LIBS@
+ EXTRA_DIST = *.1
+
+ man_MANS = args.1 scrub-files.1 mdsum.1 zerofill.1 car.1 sockaddr.1 \
+@@ -30,7 +30,7 @@
+ scrub_files_LDFLAGS = @SECURE_LOCAL@
+
+ mdsum_SOURCES = mdsum.cpp
+-mdsum_LDFLAGS = @SECURE_LOCAL@
++mdsum_LDFLAGS = @SECURE_LOCAL@ @LIBGCRYPT_LIBS@
+
+ zerofill_SOURCES = zerofill.cpp
+ zerofill_LDFLAGS = @SECURE_LOCAL@
diff --git a/dev-libs/ucommon/files/6.1/install_gcrypt.m4_file.patch b/dev-libs/ucommon/files/6.1/install_gcrypt.m4_file.patch
new file mode 100644
index 000000000000..5fb0cc3b878d
--- /dev/null
+++ b/dev-libs/ucommon/files/6.1/install_gcrypt.m4_file.patch
@@ -0,0 +1,128 @@
+diff --git a/m4/libgcrypt.m4 b/m4/libgcrypt.m4
+new file mode 100644
+--- /dev/null
++++ m4/libgcrypt.m4
+@@ -0,0 +1,123 @@
++dnl Autoconf macros for libgcrypt
++dnl Copyright (C) 2002, 2004 Free Software Foundation, Inc.
++dnl
++dnl This file is free software; as a special exception the author gives
++dnl unlimited permission to copy and/or distribute it, with or without
++dnl modifications, as long as this notice is preserved.
++dnl
++dnl This file is distributed in the hope that it will be useful, but
++dnl WITHOUT ANY WARRANTY, to the extent permitted by law; without even the
++dnl implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
++
++
++dnl AM_PATH_LIBGCRYPT([MINIMUM-VERSION,
++dnl [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND ]]])
++dnl Test for libgcrypt and define LIBGCRYPT_CFLAGS and LIBGCRYPT_LIBS.
++dnl MINIMUN-VERSION is a string with the version number optionalliy prefixed
++dnl with the API version to also check the API compatibility. Example:
++dnl a MINIMUN-VERSION of 1:1.2.5 won't pass the test unless the installed
++dnl version of libgcrypt is at least 1.2.5 *and* the API number is 1. Using
++dnl this features allows to prevent build against newer versions of libgcrypt
++dnl with a changed API.
++dnl
++AC_DEFUN([AM_PATH_LIBGCRYPT],
++[ AC_ARG_WITH(libgcrypt-prefix,
++ AC_HELP_STRING([--with-libgcrypt-prefix=PFX],
++ [prefix where LIBGCRYPT is installed (optional)]),
++ libgcrypt_config_prefix="$withval", libgcrypt_config_prefix="")
++ if test x$libgcrypt_config_prefix != x ; then
++ if test x${LIBGCRYPT_CONFIG+set} != xset ; then
++ LIBGCRYPT_CONFIG=$libgcrypt_config_prefix/bin/libgcrypt-config
++ fi
++ fi
++
++ AC_PATH_TOOL(LIBGCRYPT_CONFIG, libgcrypt-config, no)
++ tmp=ifelse([$1], ,1:1.2.0,$1)
++ if echo "$tmp" | grep ':' >/dev/null 2>/dev/null ; then
++ req_libgcrypt_api=`echo "$tmp" | sed 's/\(.*\):\(.*\)/\1/'`
++ min_libgcrypt_version=`echo "$tmp" | sed 's/\(.*\):\(.*\)/\2/'`
++ else
++ req_libgcrypt_api=0
++ min_libgcrypt_version="$tmp"
++ fi
++
++ AC_MSG_CHECKING(for LIBGCRYPT - version >= $min_libgcrypt_version)
++ ok=no
++ if test "$LIBGCRYPT_CONFIG" != "no" ; then
++ req_major=`echo $min_libgcrypt_version | \
++ sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\)/\1/'`
++ req_minor=`echo $min_libgcrypt_version | \
++ sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\)/\2/'`
++ req_micro=`echo $min_libgcrypt_version | \
++ sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\)/\3/'`
++ libgcrypt_config_version=`$LIBGCRYPT_CONFIG --version`
++ major=`echo $libgcrypt_config_version | \
++ sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\1/'`
++ minor=`echo $libgcrypt_config_version | \
++ sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\2/'`
++ micro=`echo $libgcrypt_config_version | \
++ sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\3/'`
++ if test "$major" -gt "$req_major"; then
++ ok=yes
++ else
++ if test "$major" -eq "$req_major"; then
++ if test "$minor" -gt "$req_minor"; then
++ ok=yes
++ else
++ if test "$minor" -eq "$req_minor"; then
++ if test "$micro" -ge "$req_micro"; then
++ ok=yes
++ fi
++ fi
++ fi
++ fi
++ fi
++ fi
++ if test $ok = yes; then
++ AC_MSG_RESULT([yes ($libgcrypt_config_version)])
++ else
++ AC_MSG_RESULT(no)
++ fi
++ if test $ok = yes; then
++ # If we have a recent libgcrypt, we should also check that the
++ # API is compatible
++ if test "$req_libgcrypt_api" -gt 0 ; then
++ tmp=`$LIBGCRYPT_CONFIG --api-version 2>/dev/null || echo 0`
++ if test "$tmp" -gt 0 ; then
++ AC_MSG_CHECKING([LIBGCRYPT API version])
++ if test "$req_libgcrypt_api" -eq "$tmp" ; then
++ AC_MSG_RESULT([okay])
++ else
++ ok=no
++ AC_MSG_RESULT([does not match. want=$req_libgcrypt_api got=$tmp])
++ fi
++ fi
++ fi
++ fi
++ if test $ok = yes; then
++ LIBGCRYPT_CFLAGS=`$LIBGCRYPT_CONFIG --cflags`
++ LIBGCRYPT_LIBS=`$LIBGCRYPT_CONFIG --libs`
++ ifelse([$2], , :, [$2])
++ if test x"$host" != x ; then
++ libgcrypt_config_host=`$LIBGCRYPT_CONFIG --host 2>/dev/null || echo none`
++ if test x"$libgcrypt_config_host" != xnone ; then
++ if test x"$libgcrypt_config_host" != x"$host" ; then
++ AC_MSG_WARN([[
++***
++*** The config script $LIBGCRYPT_CONFIG was
++*** built for $libgcrypt_config_host and thus may not match the
++*** used host $host.
++*** You may want to use the configure option --with-libgcrypt-prefix
++*** to specify a matching config script.
++***]])
++ fi
++ fi
++ fi
++ else
++ LIBGCRYPT_CFLAGS=""
++ LIBGCRYPT_LIBS=""
++ ifelse([$3], , :, [$3])
++ fi
++ AC_SUBST(LIBGCRYPT_CFLAGS)
++ AC_SUBST(LIBGCRYPT_LIBS)
++])
diff --git a/dev-libs/ucommon/files/disable_rtf_gen_doxy.patch b/dev-libs/ucommon/files/disable_rtf_gen_doxy.patch
new file mode 100644
index 000000000000..2fca1f7bcad7
--- /dev/null
+++ b/dev-libs/ucommon/files/disable_rtf_gen_doxy.patch
@@ -0,0 +1,18 @@
+--- Doxyfile.orig 2010-03-14 04:33:22.303087693 +0200
++++ Doxyfile 2010-03-14 04:34:34.495254330 +0200
+@@ -37,13 +37,13 @@
+ GENERATE_HTMLHELP = YES
+ GENERATE_TREEVIEW = YES
+ TREEVIEW_WIDTH = 256
+-GENERATE_LATEX = YES
++GENERATE_LATEX = NO
+ COMPACT_LATEX = YES
+ PDF_HYPERLINKS = YES
+ USE_PDFLATEX = NO
+ LATEX_BATCHMODE = YES
+ LATEX_HIDE_INDICES = NO
+-GENERATE_RTF = YES
++GENERATE_RTF = NO
+ COMPACT_RTF = YES
+ RTF_HYPERLINKS = NO
+ GENERATE_MAN = NO
diff --git a/dev-libs/ucommon/files/gcrypt_autotools.patch b/dev-libs/ucommon/files/gcrypt_autotools.patch
new file mode 100644
index 000000000000..8a5b93ffbdcd
--- /dev/null
+++ b/dev-libs/ucommon/files/gcrypt_autotools.patch
@@ -0,0 +1,62 @@
+diff --git a/Makefile.am b/Makefile.am
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -8,6 +8,8 @@
+ # WITHOUT ANY WARRANTY, to the extent permitted by law; without even the
+ # implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
+
++ACLOCAL_AMFLAGS = -I m4
++
+ AUTOMAKE_OPTIONS = no-dependencies dist-zip
+ EXTRA_DIST = autogen.sh README* *.pc.in *.spec.in *.spec *-config.in \
+ *-config.1 Doxyfile cmodel.sh BUILDS SUPPORT COPYING* COPYRIGHT \
+diff --git a/configure.ac b/configure.ac
+--- a/configure.ac
++++ b/configure.ac
+@@ -37,8 +37,12 @@
+ UCOMMON_LIBS=""
+ OPENSSL_LINK=""
+
++AM_SILENT_RULES([yes])
++
+ CHECKFLAGS="$CHECKFLAGS"
+
++m4_include([m4/libgcrypt.m4])
++
+ case "$with_crypto" in
+ ssl|openssl)
+ ssl="openssl"
+@@ -664,7 +668,8 @@
+ ;;
+ gnutls|gnu)
+ if test ! -z "$GNUTLS_LIBS" ; then
+- SECURE_LIBS="$GNUTLS_LIBS"
++ AM_PATH_LIBGCRYPT
++ SECURE_LIBS="$GNUTLS_LIBS $LIBGCRYPT_LIBS"
+ SECURE="gnutls"
+ fi
+ ;;
+diff --git a/utils/Makefile.am b/utils/Makefile.am
+--- a/utils/Makefile.am
++++ b/utils/Makefile.am
+@@ -9,9 +9,9 @@
+ # implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
+
+ MAINTAINERCLEANFILES = Makefile.in Makefile
+-AM_CXXFLAGS = -I$(top_srcdir)/inc @UCOMMON_FLAGS@
++AM_CXXFLAGS = -I$(top_srcdir)/inc @UCOMMON_FLAGS@ @LIBGCRYPT_CFLAGS@
+ INCLUDES = -I$(top_srcdir)/inc
+-LDADD = ../corelib/libucommon.la @UCOMMON_LIBS@ @UCOMMON_CLINK@
++LDADD = ../corelib/libucommon.la @UCOMMON_LIBS@ @UCOMMON_CLINK@ @LIBGCRYPT_LIBS@
+ EXTRA_DIST = *.1
+
+ man_MANS = args.1 scrub-files.1 mdsum.1 zerofill.1 car.1 sockaddr.1 pdetach.1
+@@ -27,7 +27,7 @@
+ scrub_files_LDFLAGS = @SECURE_LOCAL@
+
+ mdsum_SOURCES = mdsum.cpp
+-mdsum_LDFLAGS = @SECURE_LOCAL@
++mdsum_LDFLAGS = @SECURE_LOCAL@ @LIBGCRYPT_LIBS@
+
+ zerofill_SOURCES = zerofill.cpp
+ zerofill_LDFLAGS = @SECURE_LOCAL@
diff --git a/dev-libs/ucommon/files/install_gcrypt.m4_file.patch b/dev-libs/ucommon/files/install_gcrypt.m4_file.patch
new file mode 100644
index 000000000000..5fb0cc3b878d
--- /dev/null
+++ b/dev-libs/ucommon/files/install_gcrypt.m4_file.patch
@@ -0,0 +1,128 @@
+diff --git a/m4/libgcrypt.m4 b/m4/libgcrypt.m4
+new file mode 100644
+--- /dev/null
++++ m4/libgcrypt.m4
+@@ -0,0 +1,123 @@
++dnl Autoconf macros for libgcrypt
++dnl Copyright (C) 2002, 2004 Free Software Foundation, Inc.
++dnl
++dnl This file is free software; as a special exception the author gives
++dnl unlimited permission to copy and/or distribute it, with or without
++dnl modifications, as long as this notice is preserved.
++dnl
++dnl This file is distributed in the hope that it will be useful, but
++dnl WITHOUT ANY WARRANTY, to the extent permitted by law; without even the
++dnl implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
++
++
++dnl AM_PATH_LIBGCRYPT([MINIMUM-VERSION,
++dnl [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND ]]])
++dnl Test for libgcrypt and define LIBGCRYPT_CFLAGS and LIBGCRYPT_LIBS.
++dnl MINIMUN-VERSION is a string with the version number optionalliy prefixed
++dnl with the API version to also check the API compatibility. Example:
++dnl a MINIMUN-VERSION of 1:1.2.5 won't pass the test unless the installed
++dnl version of libgcrypt is at least 1.2.5 *and* the API number is 1. Using
++dnl this features allows to prevent build against newer versions of libgcrypt
++dnl with a changed API.
++dnl
++AC_DEFUN([AM_PATH_LIBGCRYPT],
++[ AC_ARG_WITH(libgcrypt-prefix,
++ AC_HELP_STRING([--with-libgcrypt-prefix=PFX],
++ [prefix where LIBGCRYPT is installed (optional)]),
++ libgcrypt_config_prefix="$withval", libgcrypt_config_prefix="")
++ if test x$libgcrypt_config_prefix != x ; then
++ if test x${LIBGCRYPT_CONFIG+set} != xset ; then
++ LIBGCRYPT_CONFIG=$libgcrypt_config_prefix/bin/libgcrypt-config
++ fi
++ fi
++
++ AC_PATH_TOOL(LIBGCRYPT_CONFIG, libgcrypt-config, no)
++ tmp=ifelse([$1], ,1:1.2.0,$1)
++ if echo "$tmp" | grep ':' >/dev/null 2>/dev/null ; then
++ req_libgcrypt_api=`echo "$tmp" | sed 's/\(.*\):\(.*\)/\1/'`
++ min_libgcrypt_version=`echo "$tmp" | sed 's/\(.*\):\(.*\)/\2/'`
++ else
++ req_libgcrypt_api=0
++ min_libgcrypt_version="$tmp"
++ fi
++
++ AC_MSG_CHECKING(for LIBGCRYPT - version >= $min_libgcrypt_version)
++ ok=no
++ if test "$LIBGCRYPT_CONFIG" != "no" ; then
++ req_major=`echo $min_libgcrypt_version | \
++ sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\)/\1/'`
++ req_minor=`echo $min_libgcrypt_version | \
++ sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\)/\2/'`
++ req_micro=`echo $min_libgcrypt_version | \
++ sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\)/\3/'`
++ libgcrypt_config_version=`$LIBGCRYPT_CONFIG --version`
++ major=`echo $libgcrypt_config_version | \
++ sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\1/'`
++ minor=`echo $libgcrypt_config_version | \
++ sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\2/'`
++ micro=`echo $libgcrypt_config_version | \
++ sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\3/'`
++ if test "$major" -gt "$req_major"; then
++ ok=yes
++ else
++ if test "$major" -eq "$req_major"; then
++ if test "$minor" -gt "$req_minor"; then
++ ok=yes
++ else
++ if test "$minor" -eq "$req_minor"; then
++ if test "$micro" -ge "$req_micro"; then
++ ok=yes
++ fi
++ fi
++ fi
++ fi
++ fi
++ fi
++ if test $ok = yes; then
++ AC_MSG_RESULT([yes ($libgcrypt_config_version)])
++ else
++ AC_MSG_RESULT(no)
++ fi
++ if test $ok = yes; then
++ # If we have a recent libgcrypt, we should also check that the
++ # API is compatible
++ if test "$req_libgcrypt_api" -gt 0 ; then
++ tmp=`$LIBGCRYPT_CONFIG --api-version 2>/dev/null || echo 0`
++ if test "$tmp" -gt 0 ; then
++ AC_MSG_CHECKING([LIBGCRYPT API version])
++ if test "$req_libgcrypt_api" -eq "$tmp" ; then
++ AC_MSG_RESULT([okay])
++ else
++ ok=no
++ AC_MSG_RESULT([does not match. want=$req_libgcrypt_api got=$tmp])
++ fi
++ fi
++ fi
++ fi
++ if test $ok = yes; then
++ LIBGCRYPT_CFLAGS=`$LIBGCRYPT_CONFIG --cflags`
++ LIBGCRYPT_LIBS=`$LIBGCRYPT_CONFIG --libs`
++ ifelse([$2], , :, [$2])
++ if test x"$host" != x ; then
++ libgcrypt_config_host=`$LIBGCRYPT_CONFIG --host 2>/dev/null || echo none`
++ if test x"$libgcrypt_config_host" != xnone ; then
++ if test x"$libgcrypt_config_host" != x"$host" ; then
++ AC_MSG_WARN([[
++***
++*** The config script $LIBGCRYPT_CONFIG was
++*** built for $libgcrypt_config_host and thus may not match the
++*** used host $host.
++*** You may want to use the configure option --with-libgcrypt-prefix
++*** to specify a matching config script.
++***]])
++ fi
++ fi
++ fi
++ else
++ LIBGCRYPT_CFLAGS=""
++ LIBGCRYPT_LIBS=""
++ ifelse([$3], , :, [$3])
++ fi
++ AC_SUBST(LIBGCRYPT_CFLAGS)
++ AC_SUBST(LIBGCRYPT_LIBS)
++])
diff --git a/dev-libs/ucommon/files/ucommon-5.2.2-address.patch b/dev-libs/ucommon/files/ucommon-5.2.2-address.patch
new file mode 100644
index 000000000000..142aa5941f8c
--- /dev/null
+++ b/dev-libs/ucommon/files/ucommon-5.2.2-address.patch
@@ -0,0 +1,42 @@
+This patch fixes memory errors
+
+Author: David Sugar
+
+--- commoncpp/address.cpp
++++ commoncpp/address.cpp
+@@ -360,7 +360,7 @@
+ if(ipaddr)
+ delete[] ipaddr;
+ ipaddr = new struct in_addr[1];
+- memset((void *)&ipaddr[0], 0, sizeof(ipaddr));
++ memset((void *)&ipaddr[0], 0, sizeof(struct in_addr));
+ return;
+ }
+
+@@ -498,7 +498,7 @@
+ : validator(_validator), hostname(NULL) {
+ addr_count = 1;
+ ipaddr = new struct in6_addr[1];
+- memcpy(ipaddr, &in6addr_any, sizeof(in6_addr));
++ memcpy(ipaddr, &in6addr_any, sizeof(struct in6_addr));
+ }
+
+ IPV6Address::IPV6Address(const char *address, const IPV6Validator *_validator) :
+@@ -716,7 +716,7 @@
+ if(ipaddr)
+ delete[] ipaddr;
+ ipaddr = new struct in6_addr[1];
+- memset((void *)&ipaddr[0], 0, sizeof(ipaddr));
++ memset((void *)&ipaddr[0], 0, sizeof(struct in6_addr));
+ return;
+ }
+
+@@ -796,7 +796,7 @@
+ if(ipaddr)
+ delete[] ipaddr;
+ ipaddr = new struct in6_addr[1];
+- memset((void *)&ipaddr[0], 0, sizeof(ipaddr));
++ memset((void *)&ipaddr[0], 0, sizeof(struct in6_addr));
+ return;
+ }
+
diff --git a/dev-libs/ucommon/files/ucommon-6.3.1-gcrypt_autotools.patch b/dev-libs/ucommon/files/ucommon-6.3.1-gcrypt_autotools.patch
new file mode 100644
index 000000000000..fb04130a0a85
--- /dev/null
+++ b/dev-libs/ucommon/files/ucommon-6.3.1-gcrypt_autotools.patch
@@ -0,0 +1,48 @@
+--- ucommon-6.3.1/configure.ac
++++ ucommon-6.3.1/configure.ac
+@@ -38,8 +38,12 @@
+ OPENSSL_LINK=""
+ MODULE_FLAGS="-module -shared -avoid-version"
+
++AM_SILENT_RULES([yes])
++
+ CHECKFLAGS="$CHECKFLAGS"
+
++m4_include([m4/libgcrypt.m4])
++
+ case "$with_crypto" in
+ ssl|openssl)
+ ssl="openssl"
+@@ -598,7 +602,8 @@
+ ;;
+ gnutls|gnu)
+ if test ! -z "$GNUTLS_LIBS" ; then
+- SECURE_LIBS="$GNUTLS_LIBS"
++ AM_PATH_LIBGCRYPT
++ SECURE_LIBS="$GNUTLS_LIBS $LIBGCRYPT_LIBS"
+ SECURE="gnutls"
+ fi
+ ;;
+--- ucommon-6.3.1/utils/Makefile.am
++++ ucommon-6.3.1/utils/Makefile.am
+@@ -10,9 +10,9 @@
+ # implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
+
+ MAINTAINERCLEANFILES = Makefile.in Makefile
+-AM_CXXFLAGS = -I$(top_srcdir)/inc @UCOMMON_FLAGS@
++AM_CXXFLAGS = -I$(top_srcdir)/inc @UCOMMON_FLAGS@ @LIBGCRYPT_CFLAGS@
+ AM_CPPFLAGS = -I$(top_srcdir)/inc
+-LDADD = ../corelib/libucommon.la @UCOMMON_LIBS@
++LDADD = ../corelib/libucommon.la @UCOMMON_LIBS@ @LIBGCRYPT_LIBS@
+ EXTRA_DIST = *.1 CMakeLists.txt
+
+ man_MANS = args.1 scrub-files.1 mdsum.1 zerofill.1 car.1 sockaddr.1 \
+@@ -21,7 +21,7 @@
+
+ noinst_PROGRAMS = demoSSL
+ demoSSL_SOURCES = ssl.cpp
+-demoSSL_LDFLAGS = @SECURE_LOCAL@
++demoSSL_LDFLAGS = @SECURE_LOCAL@ @LIBGCRYPT_LIBS@
+
+ args_SOURCES = args.cpp
+