summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/urdfdom_headers
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/urdfdom_headers')
-rw-r--r--dev-libs/urdfdom_headers/Manifest1
-rw-r--r--dev-libs/urdfdom_headers/metadata.xml11
-rw-r--r--dev-libs/urdfdom_headers/urdfdom_headers-0.3.0.ebuild30
-rw-r--r--dev-libs/urdfdom_headers/urdfdom_headers-9999.ebuild30
4 files changed, 72 insertions, 0 deletions
diff --git a/dev-libs/urdfdom_headers/Manifest b/dev-libs/urdfdom_headers/Manifest
new file mode 100644
index 000000000000..bb757705ff17
--- /dev/null
+++ b/dev-libs/urdfdom_headers/Manifest
@@ -0,0 +1 @@
+DIST urdfdom_headers-0.3.0.tar.gz 9931 SHA256 f059350cd85fc3b8394ed0c3bd0d4b8d14fa9c8edd09c3ee01881b4711843087 SHA512 249ea2a2cb8196eb14e005f32a3376585a5a25d599ff041b562500e2e9f17a988a8cd0dfd575853e1cfc7ca736882e856998718b702b8d0be0fc4a011d8d9dd9 WHIRLPOOL 9f7919fb1b56eedfafa8b474e2c990349f070cee10d7e48f66d5e02246583915804d5ab0c60ea98a3013b8adaabb3e0f33e814a0d79e86c2e4ced0a06e2115d8
diff --git a/dev-libs/urdfdom_headers/metadata.xml b/dev-libs/urdfdom_headers/metadata.xml
new file mode 100644
index 000000000000..4d056919cf18
--- /dev/null
+++ b/dev-libs/urdfdom_headers/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>aballier@gentoo.org</email>
+ <name>Alexis Ballier</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros/urdfdom_headers</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-libs/urdfdom_headers/urdfdom_headers-0.3.0.ebuild b/dev-libs/urdfdom_headers/urdfdom_headers-0.3.0.ebuild
new file mode 100644
index 000000000000..956b287f7714
--- /dev/null
+++ b/dev-libs/urdfdom_headers/urdfdom_headers-0.3.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros/urdfdom_headers"
+fi
+
+inherit ${SCM} cmake-utils
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~arm"
+ SRC_URI="https://github.com/ros/urdfdom_headers/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="URDF (U-Robot Description Format) headers"
+HOMEPAGE="http://ros.org/wiki/urdf"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
diff --git a/dev-libs/urdfdom_headers/urdfdom_headers-9999.ebuild b/dev-libs/urdfdom_headers/urdfdom_headers-9999.ebuild
new file mode 100644
index 000000000000..956b287f7714
--- /dev/null
+++ b/dev-libs/urdfdom_headers/urdfdom_headers-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros/urdfdom_headers"
+fi
+
+inherit ${SCM} cmake-utils
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~arm"
+ SRC_URI="https://github.com/ros/urdfdom_headers/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="URDF (U-Robot Description Format) headers"
+HOMEPAGE="http://ros.org/wiki/urdf"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"