summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2022-10-05 16:58:57 +0200
committerSebastian Pipping <sping@gentoo.org>2022-10-05 16:58:57 +0200
commite3a0f63f7d5336ddf32a0823593fc60e5bc52958 (patch)
tree4abacbc15dd5a23e027dc136311cfd28dc82072f /dev-libs/uriparser/uriparser-0.9.7.ebuild
parentdev-util/idea-community: Move dir renaming to src_unpack (diff)
downloadgentoo-e3a0f63f7d5336ddf32a0823593fc60e5bc52958.tar.gz
gentoo-e3a0f63f7d5336ddf32a0823593fc60e5bc52958.tar.bz2
gentoo-e3a0f63f7d5336ddf32a0823593fc60e5bc52958.zip
dev-libs/uriparser: 0.9.7 + EAPI 8
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Diffstat (limited to 'dev-libs/uriparser/uriparser-0.9.7.ebuild')
-rw-r--r--dev-libs/uriparser/uriparser-0.9.7.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-libs/uriparser/uriparser-0.9.7.ebuild b/dev-libs/uriparser/uriparser-0.9.7.ebuild
new file mode 100644
index 000000000000..f363133f0f2f
--- /dev/null
+++ b/dev-libs/uriparser/uriparser-0.9.7.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Strictly RFC 3986 compliant URI parsing library in C"
+HOMEPAGE="https://uriparser.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="+doc qt5 test unicode" # +doc to address warning RequiredUseDefaults
+
+REQUIRED_USE="qt5? ( doc ) test? ( unicode )"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? ( >=dev-cpp/gtest-1.8.1 )
+"
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ >=app-doc/doxygen-1.5.8
+ media-gfx/graphviz
+ qt5? ( dev-qt/qthelp:5 )
+ )
+"
+
+DOCS=( AUTHORS ChangeLog THANKS )
+
+src_configure() {
+ local mycmakeargs=(
+ -DURIPARSER_BUILD_CHAR=ON
+ -DURIPARSER_BUILD_DOCS=$(usex doc ON OFF)
+ -DURIPARSER_BUILD_TESTS=$(usex test ON OFF)
+ -DURIPARSER_BUILD_TOOLS=ON
+ -DURIPARSER_BUILD_WCHAR_T=$(usex unicode ON OFF)
+
+ # The usex wrapper is here to address this warning:
+ # One or more CMake variables were not used by the project:
+ # CMAKE_DISABLE_FIND_PACKAGE_Qt5Help
+ $(usex doc "$(cmake_use_find_package qt5 Qt5Help)")
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ if use doc && use qt5; then
+ dodoc "${BUILD_DIR}"/doc/*.qch
+ docompress -x /usr/share/doc/${PF}/${P}.qch
+ fi
+}