summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-07-31 01:02:32 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-07-31 01:02:46 +0200
commit4745abc55f8f3087dae5742db6c77f824542af9f (patch)
tree2327e5d7f3ab957dcfd022a26b211084012b0139 /dev-libs/userspace-rcu/userspace-rcu-0.11.1.ebuild
parentsys-block/mbuffer: bump to v20190725 (diff)
downloadgentoo-4745abc55f8f3087dae5742db6c77f824542af9f.tar.gz
gentoo-4745abc55f8f3087dae5742db6c77f824542af9f.tar.bz2
gentoo-4745abc55f8f3087dae5742db6c77f824542af9f.zip
dev-libs/userspace-rcu: bump to v0.11.1
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-libs/userspace-rcu/userspace-rcu-0.11.1.ebuild')
-rw-r--r--dev-libs/userspace-rcu/userspace-rcu-0.11.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/userspace-rcu/userspace-rcu-0.11.1.ebuild b/dev-libs/userspace-rcu/userspace-rcu-0.11.1.ebuild
new file mode 100644
index 000000000000..d69a055733c8
--- /dev/null
+++ b/dev-libs/userspace-rcu/userspace-rcu-0.11.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="userspace RCU (read-copy-update) library"
+HOMEPAGE="https://liburcu.org/"
+SRC_URI="https://lttng.org/files/urcu/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0/6" # subslot = soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static-libs regression-test test"
+
+DEPEND="test? ( sys-process/time )"
+
+src_configure() {
+ local myeconfargs=(
+ --enable-shared
+ $(use_enable static-libs static)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ default
+ if use regression-test; then
+ emake -C tests/regression regtest
+ fi
+}