summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/vanessa-adt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/vanessa-adt')
-rw-r--r--dev-libs/vanessa-adt/Manifest2
-rw-r--r--dev-libs/vanessa-adt/metadata.xml8
-rw-r--r--dev-libs/vanessa-adt/vanessa-adt-0.0.6.ebuild28
-rw-r--r--dev-libs/vanessa-adt/vanessa-adt-0.0.9.ebuild28
4 files changed, 66 insertions, 0 deletions
diff --git a/dev-libs/vanessa-adt/Manifest b/dev-libs/vanessa-adt/Manifest
new file mode 100644
index 000000000000..a83d9533a08c
--- /dev/null
+++ b/dev-libs/vanessa-adt/Manifest
@@ -0,0 +1,2 @@
+DIST vanessa_adt-0.0.6.tar.gz 315242 SHA256 67a5ae191a067ed46a4922d155319fd3c9872e7a83544c2a28c0d5fb69206024 SHA512 d26726b3baedffb7f7e37d62101af3d05166d70e2709caf76be2623fcd53f3e38bc4c920ea2ab95d4729aa130ab62aa3c92db388e4ffe25023bf57e29d414884 WHIRLPOOL dc29806bd6412560e22f2dd7804aeb98bce86b25baa8ec21c5d2bc1496ced67f4a1bcabfcac56bb1c44c3777f19a6eeb2f44df61bc4cf137d8a13b2037121d78
+DIST vanessa_adt-0.0.9.tar.gz 342309 SHA256 8bcbb69f64702239010541ec7d7fd86737574b6ae2fa477caa5b2cd86a12c3f1 SHA512 c32eec21879c43350389d62e74667cdd44921f054037bf33eaf869873f1b49e26b5d74bf2bed03b834f28babe072f25d499c9a717be7431b7dc42cd455526019 WHIRLPOOL b30f86fe43b668e894eb7a045b341c6482d6a1a01ab505c6395f6840c7791592977f9f166f7034ffb702a906df7f9f4085c0d85e5cbbcb108999db5c5f693617
diff --git a/dev-libs/vanessa-adt/metadata.xml b/dev-libs/vanessa-adt/metadata.xml
new file mode 100644
index 000000000000..6b1d02987300
--- /dev/null
+++ b/dev-libs/vanessa-adt/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-libs/vanessa-adt/vanessa-adt-0.0.6.ebuild b/dev-libs/vanessa-adt/vanessa-adt-0.0.6.ebuild
new file mode 100644
index 000000000000..e1d1a6ff620e
--- /dev/null
+++ b/dev-libs/vanessa-adt/vanessa-adt-0.0.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+MY_PN="${PN/-/_}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Provides Abstract Data Types (ADTs) Includes queue, dynamic array, hash and key value ADT"
+HOMEPAGE="http://www.vergenet.net/linux/vanessa/"
+SRC_URI="http://www.vergenet.net/linux/vanessa/download/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc"
+IUSE=""
+
+DEPEND=">=dev-libs/vanessa-logger-0.0.6"
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf || die "error configure"
+ emake || die "error compiling"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "error installing"
+ dodoc AUTHORS NEWS README TODO
+}
diff --git a/dev-libs/vanessa-adt/vanessa-adt-0.0.9.ebuild b/dev-libs/vanessa-adt/vanessa-adt-0.0.9.ebuild
new file mode 100644
index 000000000000..15d80dd0e823
--- /dev/null
+++ b/dev-libs/vanessa-adt/vanessa-adt-0.0.9.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+MY_PN="${PN/-/_}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Provides Abstract Data Types (ADTs) Includes queue, dynamic array, hash and key value ADT"
+HOMEPAGE="http://www.vergenet.net/linux/vanessa/"
+SRC_URI="http://www.vergenet.net/linux/vanessa/download/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/vanessa-logger-0.0.7"
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf || die "error configure"
+ emake || die "error compiling"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "error installing"
+ dodoc AUTHORS NEWS README TODO
+}