summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/vdk
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/vdk')
-rw-r--r--dev-libs/vdk/Manifest1
-rw-r--r--dev-libs/vdk/files/vdk-2.4.1-gcc4.patch28
-rw-r--r--dev-libs/vdk/files/vdk-2.4.1-gcc43.patch33
-rw-r--r--dev-libs/vdk/metadata.xml8
-rw-r--r--dev-libs/vdk/vdk-2.5.1.ebuild54
5 files changed, 124 insertions, 0 deletions
diff --git a/dev-libs/vdk/Manifest b/dev-libs/vdk/Manifest
new file mode 100644
index 000000000000..ca3188c9d101
--- /dev/null
+++ b/dev-libs/vdk/Manifest
@@ -0,0 +1 @@
+DIST vdk-2.5.1.tar.gz 1113765 SHA256 5d8f6942b8ec2f83b477f24a4e15a9945c1b1b348412d3d22a89627a35130745 SHA512 49e458785d88ab145b40e6ddcd5c7aadc950697b797d17f1ac633354abb46cd7457ea449c62d4993fca53136051d7d7810a15ab561b49e730635566021997292 WHIRLPOOL 8240ccaaffe1169fbe13b25f585f2e0df483ff633f1e0bf00d2b01b5c60e29a21d7e1a0dbe8bb90da69d0e04c330a3ebb81ffc6355afa314af3a4733e7bcd65d
diff --git a/dev-libs/vdk/files/vdk-2.4.1-gcc4.patch b/dev-libs/vdk/files/vdk-2.4.1-gcc4.patch
new file mode 100644
index 000000000000..924248b75957
--- /dev/null
+++ b/dev-libs/vdk/files/vdk-2.4.1-gcc4.patch
@@ -0,0 +1,28 @@
+diff -Naur vdk-2.4.1/vdk/vdkcomboentry.h vdk-2.4.1-ok/vdk/vdkcomboentry.h
+--- vdk-2.4.1/vdk/vdkcomboentry.h 2004-09-10 08:14:48.000000000 +0200
++++ vdk-2.4.1-ok/vdk/vdkcomboentry.h 2006-05-30 11:39:18.000000000 +0200
+@@ -51,8 +51,8 @@
+ class VDKComboEntry: public VDKObject
+ {
+ protected:
+- static int VDKComboEntry::FocusOutEvent(GtkWidget *, GdkEventFocus*, gpointer wid);
+- static int VDKComboEntry::FocusInEvent(GtkWidget *, GdkEventFocus*, gpointer wid);
++ static int FocusOutEvent(GtkWidget *, GdkEventFocus*, gpointer wid);
++ static int FocusInEvent(GtkWidget *, GdkEventFocus*, gpointer wid);
+ VDKObjectSignal s_activated, s_changed, s_selected;
+ public:
+ /*!
+diff -Naur vdk-2.4.1/vdk/vdkfilechooser.h vdk-2.4.1-ok/vdk/vdkfilechooser.h
+--- vdk-2.4.1/vdk/vdkfilechooser.h 2004-09-10 08:15:10.000000000 +0200
++++ vdk-2.4.1-ok/vdk/vdkfilechooser.h 2006-05-30 11:39:04.000000000 +0200
+@@ -106,8 +106,8 @@
+ DECLARE_EVENT_LIST(VDKFileChooser);
+ // declares two static used to initialize
+ // form display type and initial position
+- static GtkWindowType VDKFileChooser::DisplayType;
+- static GtkWindowPosition VDKFileChooser::InitialPosition;
++ static GtkWindowType DisplayType;
++ static GtkWindowPosition InitialPosition;
+ //
+ /*!
+ * Add a filter based on a pattern
diff --git a/dev-libs/vdk/files/vdk-2.4.1-gcc43.patch b/dev-libs/vdk/files/vdk-2.4.1-gcc43.patch
new file mode 100644
index 000000000000..f0fe758050c7
--- /dev/null
+++ b/dev-libs/vdk/files/vdk-2.4.1-gcc43.patch
@@ -0,0 +1,33 @@
+diff -Nurpa vdk-2.4.1.orig/vdk/entry.cc vdk-2.4.1/vdk/entry.cc
+--- vdk-2.4.1.orig/vdk/entry.cc 2008-12-15 05:16:06.000000000 +0300
++++ vdk-2.4.1/vdk/entry.cc 2008-12-15 05:16:33.000000000 +0300
+@@ -30,6 +30,7 @@
+ #include "vdk/forms.h"
+ #include "vdk/colors.h"
+ #include <string>
++#include <cstring>
+ static void
+ EntryChanged(GtkWidget* wid, gpointer gp)
+ {
+diff -Nurpa vdk-2.4.1.orig/vdk/image.cc vdk-2.4.1/vdk/image.cc
+--- vdk-2.4.1.orig/vdk/image.cc 2008-12-15 05:16:06.000000000 +0300
++++ vdk-2.4.1/vdk/image.cc 2008-12-15 05:17:41.000000000 +0300
+@@ -32,6 +32,7 @@
+ #include <vdk/tooltips.h>
+ #include <cstdio>
+ #include <string>
++#include <cstring>
+ #include <unistd.h>
+ #include <vdk/rawpixbuf.h>
+
+diff -Nurpa vdk-2.4.1.orig/vdk/vdkdate.cc vdk-2.4.1/vdk/vdkdate.cc
+--- vdk-2.4.1.orig/vdk/vdkdate.cc 2008-12-15 05:16:06.000000000 +0300
++++ vdk-2.4.1/vdk/vdkdate.cc 2008-12-15 05:20:52.000000000 +0300
+@@ -28,6 +28,7 @@
+
+ #include "vdk/vdkdate.h"
+ #include <string>
++#include <cstring>
+ #include <cstdlib>
+ #include <cstdio>
+ #include <time.h>
diff --git a/dev-libs/vdk/metadata.xml b/dev-libs/vdk/metadata.xml
new file mode 100644
index 000000000000..e111126efa21
--- /dev/null
+++ b/dev-libs/vdk/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>lang-misc</herd>
+ <upstream>
+ <remote-id type="sourceforge">vdklib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-libs/vdk/vdk-2.5.1.ebuild b/dev-libs/vdk/vdk-2.5.1.ebuild
new file mode 100644
index 000000000000..306008d8e6c0
--- /dev/null
+++ b/dev-libs/vdk/vdk-2.5.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A Visual Development Kit for RAD"
+SRC_URI="mirror://sourceforge/vdklib/${P}.tar.gz"
+HOMEPAGE="http://www.mariomotta.it/vdklib/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa ppc x86"
+IUSE="doc debug"
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ local myconf=""
+
+ # gnome and sigc USE flags need to be added later
+ # when upstream decides to re-support them - ChrisWhite
+
+ use doc && \
+ myconf="${myconf} --enable-doc-html=yes \
+ --enable-doc-latex=yes \
+ --enable-doc-man=yes" \
+ || myconf="${myconf} --enable-doc-html=no \
+ --enable-doc-latex=no \
+ --enable-doc-man=no"
+
+ use debug && \
+ myconf="${myconf} --enable-debug=yes" \
+ || myconf="${myconf} --enable-debug=no"
+
+ econf \
+ ${myconf} \
+ --enable-testvdk=no \
+ || die "econf failed"
+
+ # die non user custom CFLAGS!
+ sed -e "s/CFLAGS = .*/CFLAGS = ${CFLAGS}/" -i Makefile
+ sed -e "s/CXXFLAGS = .*/CXXFLAGS = ${CXXFLAGS}/" -i Makefile
+ sed -e "s/CFLAGS = .*/CFLAGS = ${CFLAGS}/" -i vdk/Makefile
+ sed -e "s/CXXFLAGS = .*/CXXFLAGS = ${CXXFLAGS}/" -i vdk/Makefile
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS BUGS ChangeLog INSTALL NEWS README TODO
+}