summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-10-11 00:21:31 -0400
committerMatt Turner <mattst88@gentoo.org>2022-10-11 00:21:45 -0400
commit05186e433bb475e06383773f39efddd017e7a704 (patch)
treeddf2815b694d3af2beb246bafc7f01ed5f0b028c /dev-libs/wayland-protocols/wayland-protocols-1.27.ebuild
parentmedia-libs/volpack: further fix w/ upcoming clang16 + -std=gnu89 (diff)
downloadgentoo-05186e433bb475e06383773f39efddd017e7a704.tar.gz
gentoo-05186e433bb475e06383773f39efddd017e7a704.tar.bz2
gentoo-05186e433bb475e06383773f39efddd017e7a704.zip
dev-libs/wayland-protocols: Version bump to 1.27
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/wayland-protocols/wayland-protocols-1.27.ebuild')
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-1.27.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/wayland-protocols/wayland-protocols-1.27.ebuild b/dev-libs/wayland-protocols/wayland-protocols-1.27.ebuild
new file mode 100644
index 000000000000..4eff41270cb0
--- /dev/null
+++ b/dev-libs/wayland-protocols/wayland-protocols-1.27.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Wayland protocol files"
+HOMEPAGE="https://wayland.freedesktop.org/"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/${PN}.git/"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.freedesktop.org/wayland/${PN}/-/releases/${PV}/downloads/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? ( dev-libs/wayland )
+"
+RDEPEND=""
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}