summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-04-19 14:20:33 -0400
committerMatt Turner <mattst88@gentoo.org>2024-04-19 14:20:33 -0400
commit6774b08994a359ef0a8ffd2511123ba7081908ad (patch)
tree3ae5d39f8c872cb056455cf48b8c5deb6727250e /dev-libs/wayland-protocols/wayland-protocols-1.35.ebuild
parentapp-doc/json-schema-for-humans: new package, add 0.47 (diff)
downloadgentoo-6774b08994a359ef0a8ffd2511123ba7081908ad.tar.gz
gentoo-6774b08994a359ef0a8ffd2511123ba7081908ad.tar.bz2
gentoo-6774b08994a359ef0a8ffd2511123ba7081908ad.zip
dev-libs/wayland-protocols: Version bump to 1.35
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/wayland-protocols/wayland-protocols-1.35.ebuild')
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-1.35.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/wayland-protocols/wayland-protocols-1.35.ebuild b/dev-libs/wayland-protocols/wayland-protocols-1.35.ebuild
new file mode 100644
index 000000000000..7310be696158
--- /dev/null
+++ b/dev-libs/wayland-protocols/wayland-protocols-1.35.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Wayland protocol files"
+HOMEPAGE="https://wayland.freedesktop.org/"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/${PN}.git/"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.freedesktop.org/wayland/${PN}/-/releases/${PV}/downloads/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? ( dev-libs/wayland )
+"
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}