summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-09-19 03:28:18 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-09-19 03:28:18 +0200
commitcb95ad5d68319337517acf2e81c8c51dc1402086 (patch)
treeb636557b9a8ad2050eae369f36fa9b34014605cf /dev-libs/wayland-protocols/wayland-protocols-1.7.ebuild
parentdev-libs/libinput: Version bump to 1.5.0 (diff)
downloadgentoo-cb95ad5d68319337517acf2e81c8c51dc1402086.tar.gz
gentoo-cb95ad5d68319337517acf2e81c8c51dc1402086.tar.bz2
gentoo-cb95ad5d68319337517acf2e81c8c51dc1402086.zip
dev-libs/wayland-protocols: Version bump to 1.7
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-libs/wayland-protocols/wayland-protocols-1.7.ebuild')
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-1.7.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/wayland-protocols/wayland-protocols-1.7.ebuild b/dev-libs/wayland-protocols/wayland-protocols-1.7.ebuild
new file mode 100644
index 000000000000..4674c6bd5711
--- /dev/null
+++ b/dev-libs/wayland-protocols/wayland-protocols-1.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="git://anongit.freedesktop.org/git/wayland/${PN}"
+ GIT_ECLASS="git-r3"
+ EXPERIMENTAL="true"
+ AUTOTOOLS_AUTORECONF=1
+fi
+
+inherit autotools-utils ${GIT_ECLASS}
+
+DESCRIPTION="Wayland protocol files"
+HOMEPAGE="https://wayland.freedesktop.org/"
+
+if [[ $PV = 9999* ]]; then
+ SRC_URI="${SRC_PATCHES}"
+ KEYWORDS=""
+else
+ SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/wayland"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_test() {
+ export XDG_RUNTIME_DIR="${T}/runtime-dir"
+ mkdir "${XDG_RUNTIME_DIR}" || die
+ chmod 0700 "${XDG_RUNTIME_DIR}" || die
+
+ autotools-utils_src_test
+}