summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2018-01-15 21:43:30 +0000
committerMatt Turner <mattst88@gentoo.org>2018-01-17 18:06:20 -0800
commitf6c3a84f0907ae51d03138c2f4533632d6c602e2 (patch)
treec43a7a43454ec858da7ff2883202dc1cf02844cb /dev-libs/wayland-protocols/wayland-protocols-9999.ebuild
parentapp-misc/gnote: amd64 stable wrt bug #631656 (diff)
downloadgentoo-f6c3a84f0907ae51d03138c2f4533632d6c602e2.tar.gz
gentoo-f6c3a84f0907ae51d03138c2f4533632d6c602e2.tar.bz2
gentoo-f6c3a84f0907ae51d03138c2f4533632d6c602e2.zip
dev-libs/wayland-protocols: Bump EAPI
Use autotools instead of autotools-utils which is now deprecated as per warning from repoman: inherit.deprecated 1 dev-libs/wayland-protocols/wayland-protocols-9999.ebuild please migrate from 'autotools-utils' (no replacement) on line: 13 Drop undefined usage of SRC_PATCHES Closes: https://github.com/gentoo/gentoo/pull/6875
Diffstat (limited to 'dev-libs/wayland-protocols/wayland-protocols-9999.ebuild')
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-9999.ebuild24
1 files changed, 14 insertions, 10 deletions
diff --git a/dev-libs/wayland-protocols/wayland-protocols-9999.ebuild b/dev-libs/wayland-protocols/wayland-protocols-9999.ebuild
index 15cac561d897..4948be07ff86 100644
--- a/dev-libs/wayland-protocols/wayland-protocols-9999.ebuild
+++ b/dev-libs/wayland-protocols/wayland-protocols-9999.ebuild
@@ -1,23 +1,21 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
if [[ ${PV} = 9999* ]]; then
EGIT_REPO_URI="https://anongit.freedesktop.org/git/wayland/wayland-protocols.git"
- GIT_ECLASS="git-r3"
EXPERIMENTAL="true"
- AUTOTOOLS_AUTORECONF=1
-fi
-inherit autotools-utils ${GIT_ECLASS}
+ inherit git-r3 autotools
+else
+ inherit autotools
+fi
DESCRIPTION="Wayland protocol files"
HOMEPAGE="https://wayland.freedesktop.org/"
-if [[ $PV = 9999* ]]; then
- SRC_URI="${SRC_PATCHES}"
-else
+if [[ $PV != 9999* ]]; then
SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
fi
@@ -30,10 +28,16 @@ RDEPEND="dev-libs/wayland"
DEPEND="${RDEPEND}
virtual/pkgconfig"
+src_prepare() {
+ default
+
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
src_test() {
export XDG_RUNTIME_DIR="${T}/runtime-dir"
mkdir "${XDG_RUNTIME_DIR}" || die
chmod 0700 "${XDG_RUNTIME_DIR}" || die
- autotools-utils_src_test
+ default
}