summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-08-05 14:54:22 -0700
committerMatt Turner <mattst88@gentoo.org>2019-08-05 15:02:52 -0700
commit2101a0010a020cab79c45d1bae7c9e4f1f42ca71 (patch)
tree9df797b37afa77cc504e471a8a3fdf428761b8db /dev-libs/wayland-protocols
parentdev-libs/wayland-protocols: Port to EAPI=7 (diff)
downloadgentoo-2101a0010a020cab79c45d1bae7c9e4f1f42ca71.tar.gz
gentoo-2101a0010a020cab79c45d1bae7c9e4f1f42ca71.tar.bz2
gentoo-2101a0010a020cab79c45d1bae7c9e4f1f42ca71.zip
dev-libs/wayland-protocols: Version bump to 1.18
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/wayland-protocols')
-rw-r--r--dev-libs/wayland-protocols/Manifest1
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-1.18.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/wayland-protocols/Manifest b/dev-libs/wayland-protocols/Manifest
index 2fb7fe41b511..a0950b10bf33 100644
--- a/dev-libs/wayland-protocols/Manifest
+++ b/dev-libs/wayland-protocols/Manifest
@@ -1 +1,2 @@
DIST wayland-protocols-1.17.tar.xz 107680 BLAKE2B cde978ceeaa9d71ac76cd007c511011fed6a110e772a6a9e880a5fd07a0318239a11235aac25b855d0f7ed5ae9980dd2103886092e85a92ed606c8a2f53de726 SHA512 5f3aacbba58717092036659d9b665dc10ff05ee51df61b1de38b22f0417285a74fd8a6d15ca049ad60d204f28203aa13d773c52140c7c02db2c498a6964c2643
+DIST wayland-protocols-1.18.tar.xz 108344 BLAKE2B 7e770bafa364ff96441354246801d1c6cbe561eefe864673610dc2d47e3aa5ac7cd22a2fc2925aa1060a261ed6df8b6b5ef81c33adbeb374170821feeecd651f SHA512 166be44f370a99281da442e7e2c2fc2f3169b61eeaa69263611b4e33847e93d1071f3cc89537597e1252d48d03993ce39c7d65f43b66a23c9b1551f47959e483
diff --git a/dev-libs/wayland-protocols/wayland-protocols-1.18.ebuild b/dev-libs/wayland-protocols/wayland-protocols-1.18.ebuild
new file mode 100644
index 000000000000..837f825ff1b8
--- /dev/null
+++ b/dev-libs/wayland-protocols/wayland-protocols-1.18.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Wayland protocol files"
+HOMEPAGE="https://wayland.freedesktop.org/"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/${PN}.git/"
+ inherit git-r3 autotools
+else
+ SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-libs/wayland"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_test() {
+ export XDG_RUNTIME_DIR="${T}/runtime-dir"
+ mkdir "${XDG_RUNTIME_DIR}" || die
+ chmod 0700 "${XDG_RUNTIME_DIR}" || die
+
+ default
+}