summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruno Pinto <brunoferreirapinto@gmail.com>2018-05-17 23:49:15 +0100
committerMatt Turner <mattst88@gentoo.org>2018-05-20 10:52:06 -0700
commit425b2144376f05d6274c2e6ffa2069e5d7f5b26f (patch)
treeada2cf45a04de5453b3c41aeef7394722919aec8 /dev-libs/wayland-protocols
parentxorg-2.eclass: Drop x11-proto/* support (diff)
downloadgentoo-425b2144376f05d6274c2e6ffa2069e5d7f5b26f.tar.gz
gentoo-425b2144376f05d6274c2e6ffa2069e5d7f5b26f.tar.bz2
gentoo-425b2144376f05d6274c2e6ffa2069e5d7f5b26f.zip
dev-libs/wayland-protocols: Version bump to 1.14
Closes: https://bugs.gentoo.org/655986 Closes: https://github.com/gentoo/gentoo/pull/8456
Diffstat (limited to 'dev-libs/wayland-protocols')
-rw-r--r--dev-libs/wayland-protocols/Manifest1
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-1.14.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-libs/wayland-protocols/Manifest b/dev-libs/wayland-protocols/Manifest
index 7cf2b81e4f5d..a70f5c8f40d4 100644
--- a/dev-libs/wayland-protocols/Manifest
+++ b/dev-libs/wayland-protocols/Manifest
@@ -1,3 +1,4 @@
DIST wayland-protocols-1.11.tar.xz 117852 BLAKE2B 314f247efdffd0dbc46664e2abe7fade0cb0a36ef77310660f978ea9677c33acd60b1512a5dc2fdbfc40b8e1444da7bb4089e091433bbf2bc4b5ab41e97514ca SHA512 6a6f816dd24f338182ddf11e2daa2db4f048f9153c618bd75712b6e02fccc41294c6c5f33692e858f54bab6b644b1dff49ca223ca2c8410a4afb8aa1b39e34a6
DIST wayland-protocols-1.12.tar.xz 98920 BLAKE2B f6625f91ce5ba9e4ef88b296969e67d99f2889e405f3a416ab00c62d866a78fb554ff9baccfcd8cad2662ab0e5c7908866a9a04a1f16ec36c8a5af250c42564d SHA512 84f913aeaf9786c5ddff4952fa4c318435569ccdc00c625f088b1dc9d6e61f3c439b2d217db9fcf2f0c37da954e266314749e2c3130bf3328cffdc3bdce5695a
DIST wayland-protocols-1.13.tar.xz 99680 BLAKE2B 6bb0ecf08e6b0950c50ba40cffc07d79dd95244abc7d2622f9c232bc2b1cfdaeb9fb1e9f1650ff60defc99ae184abf47f13888f44f429136f2a631afe1c2d5e8 SHA512 f35c21da289038651b75af064ec7c10779158829f578e7320faf401e980da3c958d85e5bcad00994c574cac6319a3ab975aa5483a9b438f781b767bd6303e194
+DIST wayland-protocols-1.14.tar.xz 99844 BLAKE2B 55298d24dbaa6cce017775313e9f4cfccbf3176d7ef24c786f1384111a274c3a0164ac753ebfb4e708094199105cc32ccb58cdb22711e0e0711441dde45883bb SHA512 78d2b47c462618ece0c9c19f250b28efb39436e715f624205c7705dbbae4f125ff2eafa2454e7dce527d3b13449dcb037b282bbbb9ea9d9f52809d6b8187a204
diff --git a/dev-libs/wayland-protocols/wayland-protocols-1.14.ebuild b/dev-libs/wayland-protocols/wayland-protocols-1.14.ebuild
new file mode 100644
index 000000000000..4948be07ff86
--- /dev/null
+++ b/dev-libs/wayland-protocols/wayland-protocols-1.14.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/wayland/wayland-protocols.git"
+ EXPERIMENTAL="true"
+
+ inherit git-r3 autotools
+else
+ inherit autotools
+fi
+
+DESCRIPTION="Wayland protocol files"
+HOMEPAGE="https://wayland.freedesktop.org/"
+
+if [[ $PV != 9999* ]]; then
+ SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/wayland"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_test() {
+ export XDG_RUNTIME_DIR="${T}/runtime-dir"
+ mkdir "${XDG_RUNTIME_DIR}" || die
+ chmod 0700 "${XDG_RUNTIME_DIR}" || die
+
+ default
+}