summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-08-08 12:22:26 -0700
committerMatt Turner <mattst88@gentoo.org>2018-08-08 12:25:17 -0700
commit8e3275ea6398879b0bf3ae2694adc5bff114648c (patch)
tree258e7e148bee44f47bf4633970351e4a45ac7232 /dev-libs/wayland-protocols
parentx11-apps/fonttosfnt: Version bump to 1.0.5 (diff)
downloadgentoo-8e3275ea6398879b0bf3ae2694adc5bff114648c.tar.gz
gentoo-8e3275ea6398879b0bf3ae2694adc5bff114648c.tar.bz2
gentoo-8e3275ea6398879b0bf3ae2694adc5bff114648c.zip
dev-libs/wayland-protocols: Version bump to 1.16
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-libs/wayland-protocols')
-rw-r--r--dev-libs/wayland-protocols/Manifest1
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-1.16.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-libs/wayland-protocols/Manifest b/dev-libs/wayland-protocols/Manifest
index 31518d650f4d..4ff11acf0ad5 100644
--- a/dev-libs/wayland-protocols/Manifest
+++ b/dev-libs/wayland-protocols/Manifest
@@ -1,3 +1,4 @@
DIST wayland-protocols-1.13.tar.xz 99680 BLAKE2B 6bb0ecf08e6b0950c50ba40cffc07d79dd95244abc7d2622f9c232bc2b1cfdaeb9fb1e9f1650ff60defc99ae184abf47f13888f44f429136f2a631afe1c2d5e8 SHA512 f35c21da289038651b75af064ec7c10779158829f578e7320faf401e980da3c958d85e5bcad00994c574cac6319a3ab975aa5483a9b438f781b767bd6303e194
DIST wayland-protocols-1.14.tar.xz 99844 BLAKE2B 55298d24dbaa6cce017775313e9f4cfccbf3176d7ef24c786f1384111a274c3a0164ac753ebfb4e708094199105cc32ccb58cdb22711e0e0711441dde45883bb SHA512 78d2b47c462618ece0c9c19f250b28efb39436e715f624205c7705dbbae4f125ff2eafa2454e7dce527d3b13449dcb037b282bbbb9ea9d9f52809d6b8187a204
DIST wayland-protocols-1.15.tar.xz 100816 BLAKE2B 22ab7291a4554345a40858d1051e4842ddf1b4442e4a5446f1d8ef4202c8e71307daec5a9a1cca18e7134329367063509286f85b40d9bfda52276945c5b799f2 SHA512 4a3dcd8f3219f3c43fb2399b33626a579d4fbfb94298fd5a831946e7eadfcc0538b6732f71cbc7ac2c2896362821efd5ac6b1392071b831fa80eb7b2f48845b3
+DIST wayland-protocols-1.16.tar.xz 104156 BLAKE2B 7c6403e5498c2a9f1a97dfeef780a8df0bd05287e8866619657b29f5fc79c82fcc0892a7099b5eda80720dd136f8fa3c848c05aaf870e978e09ab2b04d883c2b SHA512 8ab33021854f3e8f6bca7a9e69427e7a3e53297cc0abd4c006de7e55fac66da3ad88489a6eb4e6c28c7ba2addd96e7f055309f3c8918643b18ef78a4fb637f84
diff --git a/dev-libs/wayland-protocols/wayland-protocols-1.16.ebuild b/dev-libs/wayland-protocols/wayland-protocols-1.16.ebuild
new file mode 100644
index 000000000000..4948be07ff86
--- /dev/null
+++ b/dev-libs/wayland-protocols/wayland-protocols-1.16.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/wayland/wayland-protocols.git"
+ EXPERIMENTAL="true"
+
+ inherit git-r3 autotools
+else
+ inherit autotools
+fi
+
+DESCRIPTION="Wayland protocol files"
+HOMEPAGE="https://wayland.freedesktop.org/"
+
+if [[ $PV != 9999* ]]; then
+ SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/wayland"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_test() {
+ export XDG_RUNTIME_DIR="${T}/runtime-dir"
+ mkdir "${XDG_RUNTIME_DIR}" || die
+ chmod 0700 "${XDG_RUNTIME_DIR}" || die
+
+ default
+}