summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMykyta Holubakha <hilobakho@gmail.com>2017-07-27 22:08:32 +0300
committerDavid Seifert <soap@gentoo.org>2017-07-30 16:37:20 +0200
commit1bfb204c660c5560ee5ec44a2fee4962a7f0bc23 (patch)
treecc946aadd24e3d455cc0c2a9198a9571c4c67991 /dev-libs/wlc/wlc-0.0.10.ebuild
parentdev-libs/nss: Upstream version bump, rebase gentoo pkgconfig patch (diff)
downloadgentoo-1bfb204c660c5560ee5ec44a2fee4962a7f0bc23.tar.gz
gentoo-1bfb204c660c5560ee5ec44a2fee4962a7f0bc23.tar.bz2
gentoo-1bfb204c660c5560ee5ec44a2fee4962a7f0bc23.zip
dev-libs/wlc: version bump to 0.0.10
further separated X and xwayland USE flags enabled USE xwayland by default Closes: https://github.com/gentoo/gentoo/pull/5224
Diffstat (limited to 'dev-libs/wlc/wlc-0.0.10.ebuild')
-rw-r--r--dev-libs/wlc/wlc-0.0.10.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/dev-libs/wlc/wlc-0.0.10.ebuild b/dev-libs/wlc/wlc-0.0.10.ebuild
new file mode 100644
index 000000000000..dfd3d6fd8a5a
--- /dev/null
+++ b/dev-libs/wlc/wlc-0.0.10.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="A helper library for Wayland compositors"
+HOMEPAGE="https://github.com/Cloudef/wlc"
+
+SRC_URI="https://github.com/Cloudef/wlc/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="MIT ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X static-libs systemd +xwayland"
+
+RDEPEND="virtual/opengl
+ virtual/libudev
+ media-libs/mesa[wayland,gbm,gles2,egl]
+ x11-libs/libdrm
+ x11-libs/pixman
+ x11-libs/libxkbcommon
+ x11-misc/xkeyboard-config
+ dev-libs/libinput
+ dev-libs/wayland
+ X? (
+ x11-libs/libX11
+ x11-libs/libxcb[xkb]
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-wm
+ x11-libs/libXfixes
+ )
+ xwayland? (
+ x11-libs/libxcb[xkb]
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-wm
+ x11-base/xorg-server[wayland]
+ )
+ systemd? ( sys-apps/systemd sys-apps/dbus )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=dev-libs/wayland-protocols-1.7"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWLC_BUILD_EXAMPLES=OFF
+ -DWLC_BUILD_TESTS=OFF
+
+ -DWLC_BUILD_STATIC=$(usex static-libs)
+
+ -DWLC_X11_BACKEND_SUPPORT=$(usex X)
+ -DWLC_XWAYLAND_SUPPORT=$(usex xwayland)
+
+ $(cmake-utils_use_find_package systemd Systemd)
+ $(cmake-utils_use_find_package systemd Dbus)
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ if use X && ! use xwayland; then
+ elog "xwayland use flag is required for X11 applications support"
+ fi
+}