summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMykyta Holubakha <hilobakho@gmail.com>2016-11-21 19:48:32 +0200
committerDavid Seifert <soap@gentoo.org>2016-11-21 20:16:30 +0100
commitdbcd40da66074578b78198ef8c5857ab932e9b6c (patch)
treee5180255f02c0c2f348be2b82bb8ae668d9a2a55 /dev-libs/wlc/wlc-0.0.7.ebuild
parentnet-misc/chrony: Version bump. (diff)
downloadgentoo-dbcd40da66074578b78198ef8c5857ab932e9b6c.tar.gz
gentoo-dbcd40da66074578b78198ef8c5857ab932e9b6c.tar.bz2
gentoo-dbcd40da66074578b78198ef8c5857ab932e9b6c.zip
dev-libs/wlc: version bump to 0.0.7
Closes: https://github.com/gentoo/gentoo/pull/2883
Diffstat (limited to 'dev-libs/wlc/wlc-0.0.7.ebuild')
-rw-r--r--dev-libs/wlc/wlc-0.0.7.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-libs/wlc/wlc-0.0.7.ebuild b/dev-libs/wlc/wlc-0.0.7.ebuild
new file mode 100644
index 000000000000..a48af99a5064
--- /dev/null
+++ b/dev-libs/wlc/wlc-0.0.7.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="A helper library for Wayland compositors"
+HOMEPAGE="https://github.com/Cloudef/wlc"
+
+SRC_URI="https://github.com/Cloudef/wlc/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="MIT ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X static-libs systemd xwayland"
+
+RDEPEND="virtual/opengl
+ media-libs/mesa[wayland,gbm,gles2,egl]
+ x11-libs/libdrm
+ x11-libs/pixman
+ x11-libs/libxkbcommon
+ x11-misc/xkeyboard-config
+ dev-libs/libinput
+ dev-libs/wayland
+ X? ( x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-wm
+ x11-libs/libXfixes )
+ xwayland? ( x11-base/xorg-server[wayland] )
+ systemd? ( sys-apps/systemd sys-apps/dbus )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=dev-libs/wayland-protocols-1.7"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWLC_BUILD_EXAMPLES=OFF
+ -DWLC_BUILD_TESTS=OFF
+ -DWLC_BUILD_STATIC=$(usex static-libs)
+ -DWLC_X11_SUPPORT=$(usex X)
+ $(cmake-utils_use_find_package systemd Systemd)
+ $(cmake-utils_use_find_package systemd Dbus)
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ if use X && !use xwayland; then
+ elog "xwayland use flag is required for X11 applications support"
+ fi
+ ewarn "This wlc version does not support displaying"
+ ewarn "Qt, EFL and Gtk+<3.22 applications natively (without Xwayland)."
+ ewarn "It is required for Gtk+ 3.22 applications though."
+}