summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMykyta Holubakha <hilobakho@gmail.com>2017-03-28 14:42:05 +0300
committerGöktürk Yüksek <gokturk@gentoo.org>2017-03-30 19:30:28 -0400
commit85682d6edd3e0b127ad5850fd2785738e1704a38 (patch)
tree2e7a260b5fbef47044624ed871206e5e484d6483 /dev-libs/wlc/wlc-0.0.8-r1.ebuild
parentdev-db/sqlite: arm arm64 ppc ppc64 stable. (diff)
downloadgentoo-85682d6edd3e0b127ad5850fd2785738e1704a38.tar.gz
gentoo-85682d6edd3e0b127ad5850fd2785738e1704a38.tar.bz2
gentoo-85682d6edd3e0b127ad5850fd2785738e1704a38.zip
dev-libs/wlc: add missing virtual/libudev depend
revbumps: 0.0.7 -> 0.0.7-r1, 0.0.8 -> 0.0.8-r1
Diffstat (limited to 'dev-libs/wlc/wlc-0.0.8-r1.ebuild')
-rw-r--r--dev-libs/wlc/wlc-0.0.8-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-libs/wlc/wlc-0.0.8-r1.ebuild b/dev-libs/wlc/wlc-0.0.8-r1.ebuild
new file mode 100644
index 000000000000..44f42bf1f8ea
--- /dev/null
+++ b/dev-libs/wlc/wlc-0.0.8-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="A helper library for Wayland compositors"
+HOMEPAGE="https://github.com/Cloudef/wlc"
+
+SRC_URI="https://github.com/Cloudef/wlc/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="MIT ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X static-libs systemd xwayland"
+
+RDEPEND="virtual/opengl
+ virtual/libudev
+ media-libs/mesa[wayland,gbm,gles2,egl]
+ x11-libs/libdrm
+ x11-libs/pixman
+ x11-libs/libxkbcommon
+ x11-misc/xkeyboard-config
+ dev-libs/libinput
+ dev-libs/wayland
+ X? ( x11-libs/libX11
+ x11-libs/libxcb[xkb]
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-wm
+ x11-libs/libXfixes )
+ xwayland? ( x11-base/xorg-server[wayland] )
+ systemd? ( sys-apps/systemd sys-apps/dbus )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=dev-libs/wayland-protocols-1.7"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWLC_BUILD_EXAMPLES=OFF
+ -DWLC_BUILD_TESTS=OFF
+ -DWLC_BUILD_STATIC=$(usex static-libs)
+ -DWLC_X11_SUPPORT=$(usex X)
+ $(cmake-utils_use_find_package systemd Systemd)
+ $(cmake-utils_use_find_package systemd Dbus)
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ if use X && ! use xwayland; then
+ elog "xwayland use flag is required for X11 applications support"
+ fi
+}