summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJasen Borisov <tajjada@gmail.com>2016-05-12 11:08:10 +0100
committerIan Delaney <idella4@gentoo.org>2016-05-13 11:34:40 +0800
commit91273e7f5354dc3a5e1290192044557191db931f (patch)
tree6be0ec8fbc15bb4acb8aa93b5ddfd526a2d8be36 /dev-libs/wlc/wlc-9999.ebuild
parentapp-emulation/wine: Version bump to 1.9.9. (diff)
downloadgentoo-91273e7f5354dc3a5e1290192044557191db931f.tar.gz
gentoo-91273e7f5354dc3a5e1290192044557191db931f.tar.bz2
gentoo-91273e7f5354dc3a5e1290192044557191db931f.zip
dev-libs/wlc: add postinst message about Xwayland.
Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1459 Signed-off-by: Ian Delaney <idella4@gentoo.org>
Diffstat (limited to 'dev-libs/wlc/wlc-9999.ebuild')
-rw-r--r--dev-libs/wlc/wlc-9999.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-libs/wlc/wlc-9999.ebuild b/dev-libs/wlc/wlc-9999.ebuild
index 8af28d5b7c41..55443ba35d45 100644
--- a/dev-libs/wlc/wlc-9999.ebuild
+++ b/dev-libs/wlc/wlc-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=6
inherit git-r3 cmake-utils
-DESCRIPTION="A helper library for Wayland compositors."
+DESCRIPTION="A helper library for Wayland compositors"
HOMEPAGE="https://github.com/Cloudef/wlc"
EGIT_REPO_URI="https://github.com/Cloudef/wlc.git"
@@ -48,3 +48,11 @@ src_configure() {
cmake-utils_src_configure
}
+
+pkg_postinst() {
+ if use X && !has_version 'x11-base/xorg-server[wayland]'
+ then
+ elog "You have enabled wlc's X11 support. To use Xwayland, you must emerge"
+ elog "'x11-base/xorg-server[wayland]'."
+ fi
+}