summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-07-20 09:11:10 -0400
committerAnthony G. Basile <blueness@gentoo.org>2018-07-20 10:58:22 -0400
commit8ac4434c79c846b381ad3834e18b069f093f7099 (patch)
tree0a71ab10674830968cfba005eb24ec3fc2670fed /dev-libs/xapian
parentapp-dicts/mecab-unidic: update to EAPI 6 (diff)
downloadgentoo-8ac4434c79c846b381ad3834e18b069f093f7099.tar.gz
gentoo-8ac4434c79c846b381ad3834e18b069f093f7099.tar.bz2
gentoo-8ac4434c79c846b381ad3834e18b069f093f7099.zip
dev-libs/xapian: version bump to 1.4.7
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-libs/xapian')
-rw-r--r--dev-libs/xapian/Manifest1
-rw-r--r--dev-libs/xapian/xapian-1.4.7.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-libs/xapian/Manifest b/dev-libs/xapian/Manifest
index 6008dd0b604d..7cd3757e1b22 100644
--- a/dev-libs/xapian/Manifest
+++ b/dev-libs/xapian/Manifest
@@ -3,3 +3,4 @@ DIST xapian-core-1.2.25.tar.xz 3253292 BLAKE2B a130e26188c949d0433d017e8d13e7ecf
DIST xapian-core-1.4.4.tar.xz 2807952 BLAKE2B 92f30c063dca4bd7806c1ab025d6b75564acc3a33a129bdc2cbf496518897addb2b63bd772b648a7a199041ea7b90534fb5c4692e94e1e3ef0a7f20301e28e8e SHA512 dc88bab1d82c68b29d51c2113319ddb5d16840f3544b9d5fcc7a3671f97d58f16ddff58b865ad3521ea778cbaacf73fe7346bb514a1275f1f739283a4128d001
DIST xapian-core-1.4.5.tar.xz 2810612 BLAKE2B 7784e69e3ca064751d829173949fcde65661c2c2070fdc8392cf2b6d40874a3e5b1265e61f25dd39b33e179b3fe3842b67f33a55523c3a18e9b65528e6a23a1e SHA512 cff97a856a406583ca81164ddb704a0eeae7d8d6f94ce3b3f53d5208d657423e87dd06bdc7acb5e5904765bce1cefbc98365cde315c1d46f7b18cfba7b022ae6
DIST xapian-core-1.4.6.tar.xz 2839964 BLAKE2B ab35e3098d8cf99656539968171073683811dc9a98b7d26e389c0cb1e8d1b70f9007e0ba61defe496713cb0f304a0fed7afa253174e900c0756084ab40721573 SHA512 f08168eba26a24ea00c2219d2cdfac1d904b51162fdd98d437564786375245e00010986a7d6e9c8c7548ae19aab80434b5cb0051252f902b40db2976b1008fe2
+DIST xapian-core-1.4.7.tar.xz 2874172 BLAKE2B 917a35ca717ed4437f4a617ce0b6ac07d5936e07aac6bfa9d6878c12ed0c38e7ca994ad943b6dc7a5cd2fe131a445c5a7859f2286c2201dd048020569ce1a0bf SHA512 9e77a78bd63036966ebb9bbed91e36fef17b37c9465c8d4b7dc8041f0e24b040e6520de645babfeeade952771d145176a204328718cfa8bc2291bb6fdbe840d2
diff --git a/dev-libs/xapian/xapian-1.4.7.ebuild b/dev-libs/xapian/xapian-1.4.7.ebuild
new file mode 100644
index 000000000000..564cf8ba016f
--- /dev/null
+++ b/dev-libs/xapian/xapian-1.4.7.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eutils multilib-minimal
+
+MY_P="${PN}-core-${PV}"
+
+DESCRIPTION="Xapian Probabilistic Information Retrieval library"
+HOMEPAGE="http://www.xapian.org/"
+SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/30" # ABI version of libxapian.so
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x64-solaris"
+IUSE="doc static-libs -cpu_flags_x86_sse +cpu_flags_x86_sse2 +glass +chert +inmemory"
+
+DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="inmemory? ( chert )"
+
+S="${WORKDIR}/${MY_P}"
+
+multilib_src_configure() {
+ local myconf=""
+
+ if use cpu_flags_x86_sse2; then
+ myconf="${myconf} --enable-sse=sse2"
+ else
+ if use cpu_flags_x86_sse; then
+ myconf="${myconf} --enable-sse=sse"
+ else
+ myconf="${myconf} --disable-sse"
+ fi
+ fi
+
+ myconf="${myconf} $(use_enable static-libs static)"
+
+ use glass || myconf="${myconf} --disable-backend-glass"
+ use chert || myconf="${myconf} --disable-backend-chert"
+ use inmemory || myconf="${myconf} --disable-backend-inmemory"
+
+ myconf="${myconf} --enable-backend-remote --program-suffix="
+
+ ECONF_SOURCE=${S} econf $myconf
+}
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/xapian/postingsource.h
+ /usr/include/xapian/attributes.h
+ /usr/include/xapian/valuesetmatchdecider.h
+ /usr/include/xapian/version.h
+ /usr/include/xapian/version.h
+ /usr/include/xapian/types.h
+ /usr/include/xapian/positioniterator.h
+ /usr/include/xapian/registry.h
+)
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ # bug #573466
+ ln -sf "${D}usr/bin/xapian-config" "${D}usr/bin/xapian-config-1.3"
+
+ use doc || rm -rf "${D}usr/share/doc/xapian-core-${PV}"
+
+ dodoc AUTHORS HACKING PLATFORMS README NEWS
+
+ prune_libtool_files --all
+}
+
+multilib_src_test() {
+ emake check VALGRIND=
+}