summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2019-02-22 17:58:04 -0500
committerAnthony G. Basile <blueness@gentoo.org>2019-02-22 17:58:49 -0500
commitc769d98ebd374619987b0a8b78e4ba8929c328a7 (patch)
tree8ff1b8b266677722ffeb3e40158d4d127e367857 /dev-libs/xapian
parentprofiles/categories: add new categories (diff)
downloadgentoo-c769d98ebd374619987b0a8b78e4ba8929c328a7.tar.gz
gentoo-c769d98ebd374619987b0a8b78e4ba8929c328a7.tar.bz2
gentoo-c769d98ebd374619987b0a8b78e4ba8929c328a7.zip
dev-libs/xapian: version bump to 1.4.10
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-libs/xapian')
-rw-r--r--dev-libs/xapian/Manifest1
-rw-r--r--dev-libs/xapian/xapian-1.4.10.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-libs/xapian/Manifest b/dev-libs/xapian/Manifest
index 9adbfa2b693b..419e73330050 100644
--- a/dev-libs/xapian/Manifest
+++ b/dev-libs/xapian/Manifest
@@ -1,5 +1,6 @@
DIST xapian-core-1.2.24.tar.xz 3210192 BLAKE2B 062f0c15ce87fb64b0eec5e5e54b76c443d0581feab44791bce6925f0f77385b423218dc7006d7e095cc9764fffc73a74a067923c44f51816d94b731d001f903 SHA512 1f8ae5848f94b5f0bee03024f12ae8c336b6d85e58f7b36e885fe604f9fb962c0525e1f44e6cfcd183e811226c61b23f0f2fcc35c7d2e63544b19347a0f96c80
DIST xapian-core-1.2.25.tar.xz 3253292 BLAKE2B a130e26188c949d0433d017e8d13e7ecf6241a232d00125699ba8ed63eab9cb1651e02182fcc152f960f4e122709958632779daaaf5760fe50953a3b5b07a243 SHA512 a15b5d9b5770337519f671732f53f0642b31f08206824500d589ba309c9e91a05a30353d66ebf70a4c1cb1824b44e1c7b7630e799de3b15d645cf951a6017bfe
+DIST xapian-core-1.4.10.tar.xz 2973780 BLAKE2B 6ef86a4c02e6721f434e33ea27a37ddac9cee62f0c9eed8c6334cadb62dd544be66405dd359dd944cf1ab12742c10e786b7300c4987e33ce33da9d9df4e428d4 SHA512 fa716d6f8c04edb297d99dad4d7835f7874837ab3c39d7017e43708cde6992c596e579418be17b79772e002bd23b94169812523a1abd9519b1dd3df474f027d9
DIST xapian-core-1.4.4.tar.xz 2807952 BLAKE2B 92f30c063dca4bd7806c1ab025d6b75564acc3a33a129bdc2cbf496518897addb2b63bd772b648a7a199041ea7b90534fb5c4692e94e1e3ef0a7f20301e28e8e SHA512 dc88bab1d82c68b29d51c2113319ddb5d16840f3544b9d5fcc7a3671f97d58f16ddff58b865ad3521ea778cbaacf73fe7346bb514a1275f1f739283a4128d001
DIST xapian-core-1.4.5.tar.xz 2810612 BLAKE2B 7784e69e3ca064751d829173949fcde65661c2c2070fdc8392cf2b6d40874a3e5b1265e61f25dd39b33e179b3fe3842b67f33a55523c3a18e9b65528e6a23a1e SHA512 cff97a856a406583ca81164ddb704a0eeae7d8d6f94ce3b3f53d5208d657423e87dd06bdc7acb5e5904765bce1cefbc98365cde315c1d46f7b18cfba7b022ae6
DIST xapian-core-1.4.6.tar.xz 2839964 BLAKE2B ab35e3098d8cf99656539968171073683811dc9a98b7d26e389c0cb1e8d1b70f9007e0ba61defe496713cb0f304a0fed7afa253174e900c0756084ab40721573 SHA512 f08168eba26a24ea00c2219d2cdfac1d904b51162fdd98d437564786375245e00010986a7d6e9c8c7548ae19aab80434b5cb0051252f902b40db2976b1008fe2
diff --git a/dev-libs/xapian/xapian-1.4.10.ebuild b/dev-libs/xapian/xapian-1.4.10.ebuild
new file mode 100644
index 000000000000..ef53864e2d91
--- /dev/null
+++ b/dev-libs/xapian/xapian-1.4.10.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit eutils multilib-minimal
+
+MY_P="${PN}-core-${PV}"
+
+DESCRIPTION="Xapian Probabilistic Information Retrieval library"
+HOMEPAGE="http://www.xapian.org/"
+SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/30" # ABI version of libxapian.so
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-solaris"
+IUSE="doc static-libs -cpu_flags_x86_sse +cpu_flags_x86_sse2 +glass +chert +inmemory"
+
+DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="inmemory? ( chert )"
+
+S="${WORKDIR}/${MY_P}"
+
+multilib_src_configure() {
+ local myconf=""
+
+ if use cpu_flags_x86_sse2; then
+ myconf="${myconf} --enable-sse=sse2"
+ else
+ if use cpu_flags_x86_sse; then
+ myconf="${myconf} --enable-sse=sse"
+ else
+ myconf="${myconf} --disable-sse"
+ fi
+ fi
+
+ myconf="${myconf} $(use_enable static-libs static)"
+
+ use glass || myconf="${myconf} --disable-backend-glass"
+ use chert || myconf="${myconf} --disable-backend-chert"
+ use inmemory || myconf="${myconf} --disable-backend-inmemory"
+
+ myconf="${myconf} --enable-backend-remote --program-suffix="
+
+ ECONF_SOURCE=${S} econf $myconf
+}
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/xapian/postingsource.h
+ /usr/include/xapian/attributes.h
+ /usr/include/xapian/valuesetmatchdecider.h
+ /usr/include/xapian/version.h
+ /usr/include/xapian/version.h
+ /usr/include/xapian/types.h
+ /usr/include/xapian/positioniterator.h
+ /usr/include/xapian/registry.h
+)
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ # bug #573466
+ ln -sf "${D}usr/bin/xapian-config" "${D}usr/bin/xapian-config-1.3"
+
+ use doc || rm -rf "${D}usr/share/doc/xapian-core-${PV}"
+
+ dodoc AUTHORS HACKING PLATFORMS README NEWS
+}
+
+multilib_src_test() {
+ emake check VALGRIND=
+}