summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2022-03-31 10:59:46 +0300
committerSergey Popov <pinkbyte@gentoo.org>2022-03-31 10:59:46 +0300
commit604d33c273b64cac6649d5388d9766c7e4236693 (patch)
tree430e27400f93f831a0e32b452a8162fb4853e4ff /dev-libs/xmlrpc-c
parentdev-libs/xmlrpc-c: fix tests (diff)
downloadgentoo-604d33c273b64cac6649d5388d9766c7e4236693.tar.gz
gentoo-604d33c273b64cac6649d5388d9766c7e4236693.tar.bz2
gentoo-604d33c273b64cac6649d5388d9766c7e4236693.zip
dev-libs/xmlrpc-c: version bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Sergey Popov <pinkbyte@gentoo.org>
Diffstat (limited to 'dev-libs/xmlrpc-c')
-rw-r--r--dev-libs/xmlrpc-c/Manifest1
-rw-r--r--dev-libs/xmlrpc-c/xmlrpc-c-1.54.05.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-libs/xmlrpc-c/Manifest b/dev-libs/xmlrpc-c/Manifest
index 689a05fcafb2..b94f7f33cb34 100644
--- a/dev-libs/xmlrpc-c/Manifest
+++ b/dev-libs/xmlrpc-c/Manifest
@@ -1 +1,2 @@
DIST xmlrpc-c-1.51.06.tgz 933161 BLAKE2B 8023444e14e7e41f5433cebeb0fcb7a7323dd734f658155e117d3547b4d61ef81c189395662bf68074dcf1ec5c47ee550cd18773ce8bf0bd53cb0a1764cce945 SHA512 2927fc8c01d42b6f838d8b0c839f09a7dd0d1ddc5a3d7b36c9d479f1c7bf7fdf14923f640883f98ba66067eda0f5379737bf3a5bc9d4b9abe1a7eff7d7def066
+DIST xmlrpc-c-1.54.05.tgz 933228 BLAKE2B 50d73fe22454f04ffebf11d4b88986eaac571d107abce4e04244ad0b74469fc5233178967e3dd832a8525514912e4f835fa1ce13c439caf918a2b2d0c05021a0 SHA512 81bf8f398e9cb73b421907d8e304b9a6dc8da931f573f7296457486ade432f4a00a94b6850391690f7b229928f785522e5852db8aca68cb462c71d139e4f27b1
diff --git a/dev-libs/xmlrpc-c/xmlrpc-c-1.54.05.ebuild b/dev-libs/xmlrpc-c/xmlrpc-c-1.54.05.ebuild
new file mode 100644
index 000000000000..05c4799f8bdf
--- /dev/null
+++ b/dev-libs/xmlrpc-c/xmlrpc-c-1.54.05.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+# Upstream maintains 3 release channels: http://xmlrpc-c.sourceforge.net/release.html
+# 1. Only the "Super Stable" series is released as a tarball
+# 2. SVN tagging of releases seems spotty: http://svn.code.sf.net/p/xmlrpc-c/code/release_number/
+# Because of this, we are following the "Super Stable" release channel
+
+DESCRIPTION="A lightweigt RPC library based on XML and HTTP"
+HOMEPAGE="http://xmlrpc-c.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0/4.54"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="abyss +cgi +curl +cxx +libxml2 threads test"
+
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="test? ( abyss curl cxx )"
+
+RDEPEND="
+ sys-libs/ncurses:0=[${MULTILIB_USEDEP}]
+ sys-libs/readline:0=[${MULTILIB_USEDEP}]
+ curl? ( net-misc/curl[${MULTILIB_USEDEP}] )
+ libxml2? ( dev-libs/libxml2[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ use curl || ewarn "Curl support disabled: No client library will be built"
+}
+
+src_prepare() {
+ sed -i \
+ -e "/CFLAGS_COMMON/s|-g -O3$||" \
+ -e "/CXXFLAGS_COMMON/s|-g$||" \
+ common.mk || die
+
+ default
+
+ # Out-of-source install phase is broken
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-libwww-client \
+ --disable-wininet-client \
+ --without-libwww-ssl \
+ $(use_enable abyss abyss-server) \
+ $(use_enable cgi cgi-server) \
+ $(use_enable curl curl-client) \
+ $(use_enable cxx cplusplus) \
+ $(use_enable libxml2 libxml2-backend) \
+ $(use_enable threads abyss-threads)
+}
+
+multilib_src_compile() {
+ default_src_compile
+ # Needed for tests, bug #836469
+ cp "${BUILD_DIR}"/include/xmlrpc-c/config.h "${S}"/include/xmlrpc-c || die
+ # Tools building is broken in this release
+ #multilib_is_native_abi && use tools && emake -rC "${S}"/tools
+}
+
+#multilib_src_install_all() {
+# # Tools building is broken in this release
+# #use tools && emake DESTDIR="${D}" -rC "${S}"/tools install
+#}