summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2020-04-15 11:53:41 +0200
committerGuilherme Amadio <amadio@gentoo.org>2020-04-15 11:55:33 +0200
commitcf7f84fee2a61b58f168762efefb4259a261679e (patch)
tree150e27298b8f8a992a332206d02753c1e484c5e1 /dev-libs/xxhash/xxhash-0.7.3.ebuild
parentdev-perl/mime-construct: Remove old 1.900.0-r1 (diff)
downloadgentoo-cf7f84fee2a61b58f168762efefb4259a261679e.tar.gz
gentoo-cf7f84fee2a61b58f168762efefb4259a261679e.tar.bz2
gentoo-cf7f84fee2a61b58f168762efefb4259a261679e.zip
dev-libs/xxhash: version bump to 0.7.3
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'dev-libs/xxhash/xxhash-0.7.3.ebuild')
-rw-r--r--dev-libs/xxhash/xxhash-0.7.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/xxhash/xxhash-0.7.3.ebuild b/dev-libs/xxhash/xxhash-0.7.3.ebuild
new file mode 100644
index 000000000000..f99938d54c17
--- /dev/null
+++ b/dev-libs/xxhash/xxhash-0.7.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Extremely fast non-cryptographic hash algorithm"
+HOMEPAGE="https://www.xxhash.com"
+SRC_URI="https://github.com/Cyan4973/xxHash/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2 GPL-2+"
+# https://abi-laboratory.pro/tracker/timeline/xxhash
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="static-libs"
+
+S="${WORKDIR}/xxHash-${PV}"
+
+src_compile() {
+ PREFIX="${EPREFIX}/usr" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)"
+}
+
+src_install() {
+ PREFIX="${EPREFIX}/usr" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ MANDIR="${EPREFIX}/usr/share/man/man1" \
+ emake DESTDIR="${D}" install
+
+ if ! use static-libs ; then
+ rm "${ED}"/usr/$(get_libdir)/libxxhash.a || die
+ fi
+}