summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-03-11 21:02:45 +0100
committerHans de Graaff <graaff@gentoo.org>2019-03-11 21:40:12 +0100
commitc83deef5496190a13784839a9b48e20a77458346 (patch)
treed6d986cc8cf6af7dd1dc6c5bd328f0ec076b7d0c /dev-libs/yajl/yajl-2.1.0-r2.ebuild
parentdev-util/trace-cmd: Remove old (diff)
downloadgentoo-c83deef5496190a13784839a9b48e20a77458346.tar.gz
gentoo-c83deef5496190a13784839a9b48e20a77458346.tar.bz2
gentoo-c83deef5496190a13784839a9b48e20a77458346.zip
dev-libs/yajl: fix pkg-config file install
Fixes: https://bugs.gentoo.org/677870 Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-libs/yajl/yajl-2.1.0-r2.ebuild')
-rw-r--r--dev-libs/yajl/yajl-2.1.0-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/yajl/yajl-2.1.0-r2.ebuild b/dev-libs/yajl/yajl-2.1.0-r2.ebuild
new file mode 100644
index 000000000000..9abc15c922f5
--- /dev/null
+++ b/dev-libs/yajl/yajl-2.1.0-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-multilib vcs-snapshot
+
+DESCRIPTION="Small event-driven (SAX-style) JSON parser"
+HOMEPAGE="https://lloyd.github.com/yajl/"
+SRC_URI="https://github.com/lloyd/yajl/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+PATCHES=( "${FILESDIR}"/${P}-uclibc.patch "${FILESDIR}"/${P}-pkg-config.patch )
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ multilib_copy_sources
+}
+
+src_test() {
+ run_test() {
+ cd "${BUILD_DIR}"/test/parsing
+ ./run_tests.sh ./yajl_test || die
+ }
+ multilib_parallel_foreach_abi run_test
+}
+
+src_install() {
+ cmake-multilib_src_install
+
+ use static-libs || \
+ find "${D}" -name libyajl_s.a -delete
+}