summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2016-03-19 00:20:06 -0500
committerDoug Goldstein <cardoe@gentoo.org>2016-03-21 16:49:22 -0500
commit51d9a01c1ab7a7a8b2c97a400fe785c57806d13b (patch)
tree3194b44706c6524794f08125b9a6db972464c0d7 /dev-libs/yajl/yajl-2.1.0.ebuild
parentdev-libs/yajl: bump latest legacy yajl (diff)
downloadgentoo-51d9a01c1ab7a7a8b2c97a400fe785c57806d13b.tar.gz
gentoo-51d9a01c1ab7a7a8b2c97a400fe785c57806d13b.tar.bz2
gentoo-51d9a01c1ab7a7a8b2c97a400fe785c57806d13b.zip
dev-libs/yajl: version bump
Bump to the latest 2.x stable version. Set sub-SLOT to 2 to help with dependencies that need to be rebuilt. Update license to ISC, which is what upstream has used since 2.0.0. Package-Manager: portage-2.2.26 Signed-off-by: Doug Goldstein <cardoe@gentoo.org>
Diffstat (limited to 'dev-libs/yajl/yajl-2.1.0.ebuild')
-rw-r--r--dev-libs/yajl/yajl-2.1.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/yajl/yajl-2.1.0.ebuild b/dev-libs/yajl/yajl-2.1.0.ebuild
new file mode 100644
index 000000000000..db8d0b9d31dd
--- /dev/null
+++ b/dev-libs/yajl/yajl-2.1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils cmake-multilib vcs-snapshot
+
+DESCRIPTION="Small event-driven (SAX-style) JSON parser"
+HOMEPAGE="https://lloyd.github.com/yajl/"
+SRC_URI="https://github.com/lloyd/yajl/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+src_prepare() {
+ epatch_user
+
+ multilib_copy_sources
+}
+
+src_test() {
+ run_test() {
+ cd "${BUILD_DIR}"/test
+ ./run_tests.sh ./yajl_test || die
+ }
+ multilib_parallel_foreach_abi run_test
+}
+
+src_install() {
+ cmake-multilib_src_install
+
+ use static-libs || \
+ find "${D}" -name libyajl_s.a -delete
+}