summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2018-01-28 22:14:38 -0500
committerAlexandre Rostovtsev <tetromino@gentoo.org>2018-01-28 22:15:27 -0500
commit002f07d42fc7adad88f740c19a0fc44f1f88dc87 (patch)
tree3d4459434cd407ba2e0d24a50c2c1afb16bd8fd2 /dev-libs
parentsci-physics/lammps: version bump (diff)
downloadgentoo-002f07d42fc7adad88f740c19a0fc44f1f88dc87.tar.gz
gentoo-002f07d42fc7adad88f740c19a0fc44f1f88dc87.tar.bz2
gentoo-002f07d42fc7adad88f740c19a0fc44f1f88dc87.zip
dev-libs/libsass: version bump to 3.4.8
Package-Manager: Portage-2.3.20, Repoman-2.3.6
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libsass/Manifest1
-rw-r--r--dev-libs/libsass/libsass-3.4.8.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-libs/libsass/Manifest b/dev-libs/libsass/Manifest
index 09cff5a0af87..a03bf97da799 100644
--- a/dev-libs/libsass/Manifest
+++ b/dev-libs/libsass/Manifest
@@ -1 +1,2 @@
DIST libsass-3.4.7.tar.gz 319824 BLAKE2B ca3e7091816474e318fb1eaefa01e5e361a66715b6267500a93f80dfc8b34bdc595e6ddc4b1872e4399093468d4ac06a9760685d8941d92f18e1834df7715b04 SHA512 5d743d4345b11e9e5315aa858637d3388d2b464150a46bc8a712e1e5d1b3df9c1e6b4dcac26f91827f1c38db24a5a084d04c0962a428f2994f42ad66a25b35a8
+DIST libsass-3.4.8.tar.gz 320415 BLAKE2B dc7b377134ffe6619687e3a7f4c47b5a5d79d0dc530c2d301845f2af0956b674a840bb8cacbc764abfb15a001b15db2642c3f51142c746e98a15cca184c51adf SHA512 5cbf5621ee45111f4a31113d2ea39f03be51d42c6e8978e7b2bfd89a8863c262a19fc17a31b910c9547dc687696b1fd4e17f2d050ec2afc4c4266dbc2ad00b72
diff --git a/dev-libs/libsass/libsass-3.4.8.ebuild b/dev-libs/libsass/libsass-3.4.8.ebuild
new file mode 100644
index 000000000000..78b45f223a4e
--- /dev/null
+++ b/dev-libs/libsass/libsass-3.4.8.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils ltprune multilib-minimal
+
+if [[ ${PV} = *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/sass/libsass.git"
+ inherit git-r3
+ KEYWORDS=
+else
+ SRC_URI="https://github.com/sass/libsass/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux"
+fi
+
+DESCRIPTION="A C/C++ implementation of a Sass CSS compiler"
+HOMEPAGE="https://github.com/sass/libsass"
+LICENSE="MIT"
+SLOT="0/0" # libsass soname
+IUSE="static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+DOCS=( Readme.md SECURITY.md )
+
+src_prepare() {
+ default
+
+ if [[ ${PV} != *9999 ]]; then
+ [[ -f VERSION ]] || echo "${PV}" > VERSION
+ fi
+ eautoreconf
+
+ # only sane way to deal with various version-related scripts, env variables etc.
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --enable-shared
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+ prune_libtool_files
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ dodoc -r "${S}/docs"
+}