summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-09-08 20:19:41 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-08 20:20:00 +0200
commit013a4924bcee93f3df06c556cc28a9b426830625 (patch)
treecff5eb8c6de52876fcd0e2519e41d48c548b4631 /dev-libs
parentmedia-libs/freetype: Bump to version 2.7 (diff)
downloadgentoo-013a4924bcee93f3df06c556cc28a9b426830625.tar.gz
gentoo-013a4924bcee93f3df06c556cc28a9b426830625.tar.bz2
gentoo-013a4924bcee93f3df06c556cc28a9b426830625.zip
dev-libs/oniguruma: Bump to EAPI=6, remove autotools-multilib.eclass
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/oniguruma/oniguruma-5.9.5-r1.ebuild28
1 files changed, 16 insertions, 12 deletions
diff --git a/dev-libs/oniguruma/oniguruma-5.9.5-r1.ebuild b/dev-libs/oniguruma/oniguruma-5.9.5-r1.ebuild
index 928a15d0ef94..ef40ae4145c5 100644
--- a/dev-libs/oniguruma/oniguruma-5.9.5-r1.ebuild
+++ b/dev-libs/oniguruma/oniguruma-5.9.5-r1.ebuild
@@ -2,12 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
# Needed for a sane .so versionning on fbsd, please dont drop
-AUTOTOOLS_AUTORECONF=1
-
-inherit eutils autotools-multilib
+inherit autotools multilib-minimal
MY_P=onig-${PV}
@@ -25,15 +23,21 @@ DOCS=( AUTHORS HISTORY README{,.ja} doc/{API,FAQ,RE}{,.ja} )
S=${WORKDIR}/${MY_P}
-src_configure() {
- local myeconfargs=(
- $(use_enable combination-explosion-check)
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} econf \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ $(use_enable combination-explosion-check) \
$(use_enable crnl-as-line-terminator)
- )
- autotools-multilib_src_configure
}
-src_install() {
- autotools-multilib_src_install
- use static-libs || prune_libtool_files
+multilib_src_install_all() {
+ einstalldocs
+ find "${D}" -name '*.la' -delete || die
}