summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2019-12-13 09:30:17 +0300
committerEray Aslan <eras@gentoo.org>2019-12-13 09:30:17 +0300
commit0172960bd597d0e783d4c2034234d5addae1fbef (patch)
treed33a9baf02fa8c789141cc0289d19af51185c3e6 /dev-libs
parentsys-kernel/ck-sources: drop deblob, Fix extraversion (diff)
downloadgentoo-0172960bd597d0e783d4c2034234d5addae1fbef.tar.gz
gentoo-0172960bd597d0e783d4c2034234d5addae1fbef.tar.bz2
gentoo-0172960bd597d0e783d4c2034234d5addae1fbef.zip
dev-libs/libverto: bump to 0.3.1
and cleanup Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Eray Aslan <eras@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libverto/Manifest1
-rw-r--r--dev-libs/libverto/libverto-0.3.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-libs/libverto/Manifest b/dev-libs/libverto/Manifest
index 21ca6f940acf..3bfbe6547536 100644
--- a/dev-libs/libverto/Manifest
+++ b/dev-libs/libverto/Manifest
@@ -1,2 +1,3 @@
DIST libverto-0.2.5.tar.gz 349722 BLAKE2B fd46b1fd1500d4732baa2d461e4b490386ff54efa8a23f06f40048e1624b4698cfedcfda79cc0a21c9a77050baafe8572835f1c0d174873772afe46b199a6294 SHA512 d57a7f86e714d3fbed391984de3356d8a2769f846985769c1be7d881647c1be95a5fc6a82bba1660ef3241aa1a40150b5e005af6f35dc32473facfdea49c556e
DIST libverto-0.3.0.tar.gz 380822 BLAKE2B 7dd31e62a4f4d8ce5cdb77ba96b9e4c957b117ade67f2fb8d38c98e05334fd952386f5690bbe49eba60c545c02ef99dcf63dee3fb17910589013b2868ee24139 SHA512 af4fec9cd20058c1db404443004c2b6c98bcacd0742369bb91f46dde6a35358e44f659bdfef30ab113e112ac1afb3156b098f5b5e2f4a58d1f4cd949abf0f57f
+DIST libverto-0.3.1.tar.gz 383390 BLAKE2B 2d8366d85c2a02becf8fa9224d195a8d85f64aab735a0101997a52dd99750537b181a6dd2fc494b435b949b4a9cb785acb7222ba3f2424b7a7ddcf5d3c832387 SHA512 baef4fd280e0cb30167743608fd5a950fb4340eeb89e3630a0f63f8eab4d56f0f894a2e3283583b7ed8774d5e896c44e2c68c25882d95a07350f980af36b8740
diff --git a/dev-libs/libverto/libverto-0.3.1.ebuild b/dev-libs/libverto/libverto-0.3.1.ebuild
new file mode 100644
index 000000000000..382aef72f9dd
--- /dev/null
+++ b/dev-libs/libverto/libverto-0.3.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="Main event loop abstraction library"
+HOMEPAGE="https://github.com/latchset/libverto/"
+SRC_URI="https://github.com/latchset/libverto/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+IUSE="glib +libev libevent tevent +threads static-libs"
+
+DEPEND="glib? ( >=dev-libs/glib-2.34.3[${MULTILIB_USEDEP}] )
+ libev? ( >=dev-libs/libev-4.15[${MULTILIB_USEDEP}] )
+ libevent? ( >=dev-libs/libevent-2.0.21[${MULTILIB_USEDEP}] )
+ tevent? ( >=sys-libs/tevent-0.9.19[${MULTILIB_USEDEP}] )"
+
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="|| ( glib libev libevent tevent ) "
+
+DOCS=( AUTHORS ChangeLog NEWS INSTALL README )
+
+src_prepare() {
+ default
+ # known problem uptream with tevent write test. tevent does not fire a
+ # callback on error, but we explicitly test for this behaviour. Do not run
+ # tevent tests for now.
+ sed -i -e 's/def HAVE_TEVENT/ 0/' tests/test.h || die
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf \
+ $(use_with glib) \
+ $(use_with libev) \
+ $(use_with libevent) \
+ $(use_with tevent) \
+ $(use_with threads pthread) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ default
+ use static-libs || find "${ED}" -name '*.la' -delete
+}