summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-06-01 04:36:35 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-06-01 04:36:35 -0400
commit01a957985e2d9a364ef0eba37d26ad356cab6bcf (patch)
tree13ea4af873acac8970d987b1fa18a670ef3bd406 /dev-libs
parentprofiles: lift the mask on =dev-libs/libressl-2.3* (diff)
downloadgentoo-01a957985e2d9a364ef0eba37d26ad356cab6bcf.tar.gz
gentoo-01a957985e2d9a364ef0eba37d26ad356cab6bcf.tar.bz2
gentoo-01a957985e2d9a364ef0eba37d26ad356cab6bcf.zip
dev-libs/libressl: bump to versions 2.2.8, 2.3.5 and 2.4.0
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libressl/Manifest3
-rw-r--r--dev-libs/libressl/libressl-2.2.8.ebuild47
-rw-r--r--dev-libs/libressl/libressl-2.3.5.ebuild51
-rw-r--r--dev-libs/libressl/libressl-2.4.0.ebuild51
4 files changed, 152 insertions, 0 deletions
diff --git a/dev-libs/libressl/Manifest b/dev-libs/libressl/Manifest
index 8764dc8f622b..b12c3eb3eeb0 100644
--- a/dev-libs/libressl/Manifest
+++ b/dev-libs/libressl/Manifest
@@ -1,2 +1,5 @@
DIST libressl-2.2.7.tar.gz 2958862 SHA256 7e2c68b383bba8efb7dce5ea1eccfda77048547d1d2a7355c072efd7ccd893cd SHA512 562394e84903c5b121da21cb3f45744df80b06d8717efc5567a6f663d1dcb8dd2bf505db7ab78ea83c9223a62c1bc541bf6c905720d73410bff352a63f5f8fc1 WHIRLPOOL 5c4eadba9e1e46573ac07edeaf01a7c203877cbfedce7abdf618dfa4fe034420d0a1bac09c08190cf24a8c591ec6f1f7452ad5c0f7b5164b42500c0766a3dca4
+DIST libressl-2.2.8.tar.gz 2958840 SHA256 d1051477dbc5dc36f148b53aa959c3e2a0aaa5944eb04c89dd549254825fbb0b SHA512 3fd5b9c967e6310f9ce53220160e76f7453462af48c5771aa05386232682a5b48e9d26fa0bb176246292bef42a0727b078293729312a821bcae4458c21eab115 WHIRLPOOL 36c60731236695e916b363f792448bdf90cd67214fe6177c157c77726d7327bf50d23c18255c6ddff3ff60f3f96996203cb7c1bf007c61cb146f23b496c44920
DIST libressl-2.3.4.tar.gz 3013286 SHA256 7a1135b2620f78928e89538c211a4df1d9415994001d1e7c9178c6b6d72de6a9 SHA512 468531303df47d52f06402db527737361e45424562e614e7575ba287ebfff9804f73c080d2f7530e26e483cd4245c131c2dd63a9509ec6646585c49f84411739 WHIRLPOOL c5afa71f9b9106cdc46a256e9e46c9bbd81e87427d570e05866074290406743303047a9e61f16b7cfa576e4e6ee1f369062c05767856f08c166b50db9cec6537
+DIST libressl-2.3.5.tar.gz 3013316 SHA256 f425275ce7debcc7282c9dcb46bd6eebbaf41ac60136e2fd32d8fd60be8b753b SHA512 b73271ee05ba1bdffbfde02f17a33acf38738a4dfbe69be1bdd8f13a1f03a5fdab4c62a5f62f94c4128ad0d7ad1e6796e554c772d9f0563c61b7da75a8bb1e23 WHIRLPOOL 89dfbeb15a156d5ab6765591b6439ef90d8bfcfc1a3ebf91a2c44e15ed12f2cfd6df6cbe352dc8c5be749b8b7f562ebe06990c99f4a2eb99406738ea5a3b9dd7
+DIST libressl-2.4.0.tar.gz 3024184 SHA256 7e6000cfb9438fbfc7fe7fe0572af587e2f2a36bbdb95408e9874758d0c3382e SHA512 147f6bc3cb17d7769e6cc7d947d66bcfa6904a1669eba791f3805c00db3349732adcc1f9e7921d9a8112b0a395b07a426ae1ed0c95580ebea4d94c723a8f133f WHIRLPOOL d0d2fc4454551333d6f90e9b17eac33eacab643a6e270f3a4dac66c115a2c8ffeba948ce5299710e19b83b276aae324bf78dfd7d4150eb35ddbb8c76efcbe681
diff --git a/dev-libs/libressl/libressl-2.2.8.ebuild b/dev-libs/libressl/libressl-2.2.8.ebuild
new file mode 100644
index 000000000000..1dcdc69e6f00
--- /dev/null
+++ b/dev-libs/libressl/libressl-2.2.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib-minimal
+
+DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
+HOMEPAGE="http://www.libressl.org/"
+SRC_URI="http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
+
+LICENSE="ISC openssl"
+SLOT="0/35" # reflects ABI of libcrypto.so and libssl.so
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86"
+IUSE="+asm static-libs"
+
+RDEPEND="!dev-libs/openssl:0"
+DEPEND="${RDEPEND}"
+PDEPEND="app-misc/ca-certificates"
+
+src_prepare() {
+ touch crypto/Makefile.in
+ sed -i \
+ -e '/^[ \t]*CFLAGS=/s#-g ##' \
+ -e '/^[ \t]*CFLAGS=/s#-g"#"#' \
+ -e '/^[ \t]*CFLAGS=/s#-O2 ##' \
+ -e '/^[ \t]*CFLAGS=/s#-O2"#"#' \
+ -e '/^[ \t]*USER_CFLAGS=/s#-O2 ##' \
+ -e '/^[ \t]*USER_CFLAGS=/s#-O2"#"#' \
+ configure || die "fixing CFLAGS failed"
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable asm) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_test() {
+ emake check
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files
+}
diff --git a/dev-libs/libressl/libressl-2.3.5.ebuild b/dev-libs/libressl/libressl-2.3.5.ebuild
new file mode 100644
index 000000000000..f65fed526d33
--- /dev/null
+++ b/dev-libs/libressl/libressl-2.3.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib-minimal
+
+DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
+HOMEPAGE="http://www.libressl.org/"
+SRC_URI="http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
+
+LICENSE="ISC openssl"
+# Reflects ABI of libcrypto.so and libssl.so. Since these can differ,
+# we'll try to use the max of either. However, if either change between
+# versions, we have to change the subslot to trigger rebuild of consumers.
+SLOT="0/38"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86"
+IUSE="+asm static-libs"
+
+RDEPEND="!dev-libs/openssl:0"
+DEPEND="${RDEPEND}"
+PDEPEND="app-misc/ca-certificates"
+
+src_prepare() {
+ touch crypto/Makefile.in
+
+ sed -i \
+ -e '/^[ \t]*CFLAGS=/s#-g ##' \
+ -e '/^[ \t]*CFLAGS=/s#-g"#"#' \
+ -e '/^[ \t]*CFLAGS=/s#-O2 ##' \
+ -e '/^[ \t]*CFLAGS=/s#-O2"#"#' \
+ -e '/^[ \t]*USER_CFLAGS=/s#-O2 ##' \
+ -e '/^[ \t]*USER_CFLAGS=/s#-O2"#"#' \
+ configure || die "fixing CFLAGS failed"
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable asm) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_test() {
+ emake check
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files
+}
diff --git a/dev-libs/libressl/libressl-2.4.0.ebuild b/dev-libs/libressl/libressl-2.4.0.ebuild
new file mode 100644
index 000000000000..e6602882fd3a
--- /dev/null
+++ b/dev-libs/libressl/libressl-2.4.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib-minimal
+
+DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
+HOMEPAGE="http://www.libressl.org/"
+SRC_URI="http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
+
+LICENSE="ISC openssl"
+# Reflects ABI of libcrypto.so and libssl.so. Since these can differ,
+# we'll try to use the max of either. However, if either change between
+# versions, we have to change the subslot to trigger rebuild of consumers.
+SLOT="0/39"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86"
+IUSE="+asm static-libs"
+
+RDEPEND="!dev-libs/openssl:0"
+DEPEND="${RDEPEND}"
+PDEPEND="app-misc/ca-certificates"
+
+src_prepare() {
+ touch crypto/Makefile.in
+
+ sed -i \
+ -e '/^[ \t]*CFLAGS=/s#-g ##' \
+ -e '/^[ \t]*CFLAGS=/s#-g"#"#' \
+ -e '/^[ \t]*CFLAGS=/s#-O2 ##' \
+ -e '/^[ \t]*CFLAGS=/s#-O2"#"#' \
+ -e '/^[ \t]*USER_CFLAGS=/s#-O2 ##' \
+ -e '/^[ \t]*USER_CFLAGS=/s#-O2"#"#' \
+ configure || die "fixing CFLAGS failed"
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable asm) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_test() {
+ emake check
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files
+}