summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-05-16 23:44:37 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-05-17 01:11:56 +0200
commit0e8d506824ab6c2b8aab82471c2e36147b56e049 (patch)
tree17c86cd87ab4def467db733d2ee7bbd06617e238 /dev-libs
parentnet-firewall/shorewall: Bump to v5.2.0.3 (diff)
downloadgentoo-0e8d506824ab6c2b8aab82471c2e36147b56e049.tar.gz
gentoo-0e8d506824ab6c2b8aab82471c2e36147b56e049.tar.bz2
gentoo-0e8d506824ab6c2b8aab82471c2e36147b56e049.zip
dev-libs/librelp: Bump to v1.2.16
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/librelp/Manifest1
-rw-r--r--dev-libs/librelp/librelp-1.2.16.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-libs/librelp/Manifest b/dev-libs/librelp/Manifest
index a2ca2208800f..aecd425fe0d0 100644
--- a/dev-libs/librelp/Manifest
+++ b/dev-libs/librelp/Manifest
@@ -1 +1,2 @@
DIST librelp-1.2.15.tar.gz 440273 BLAKE2B dba423e206bdbcbfb351ab691f777d4c78f25d9042ffe2cdac01bc4e7e07eb7c02301ab0d8942a73d688eaf28b43d9f77aa94cc88a258dee1b28dac94a13954e SHA512 9cf52c82c8e61f6970a83ead60da4bc64ab56a2bda42fedf184a1ae60c28f66d565a0c3a8720b55b9a2e5e3ffb7ec35601158f634c8f2965f8c0d3b4f1c15568
+DIST librelp-1.2.16.tar.gz 474456 BLAKE2B b528aaa66e9d52d5304510f86400067e1baea44be487f8cb176aeb146924bc35af24a403e849376e74614fb060093b48a3afe9d6c5da56bbf4dc37a6740478cc SHA512 54c101281c94046e4f8d6f77e73ab52874408e62c77f3dfa29ec0b294f39c216637674cc0bf1b7e04173557b3f21bfa74b7be1aafa3ff2771acd41d1d067d3a3
diff --git a/dev-libs/librelp/librelp-1.2.16.ebuild b/dev-libs/librelp/librelp-1.2.16.ebuild
new file mode 100644
index 000000000000..e82777d8801b
--- /dev/null
+++ b/dev-libs/librelp/librelp-1.2.16.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit autotools
+
+DESCRIPTION="An easy to use library for the RELP protocol"
+HOMEPAGE="http://www.librelp.com/"
+SRC_URI="http://download.rsyslog.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+ doc? ( FDL-1.3 )"
+
+# subslot = soname version
+SLOT="0/0.4.0"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~sparc ~x86"
+IUSE="debug doc +ssl static-libs"
+
+RDEPEND="
+ ssl? ( >=net-libs/gnutls-3.3.17.1:0= )
+"
+
+DEPEND="
+ ssl? ( >=net-libs/gnutls-3.3.17.1:0= )
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ sed -i \
+ -e 's/ -g"/"/g' \
+ configure.ac || die "sed failed"
+
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable ssl tls)
+ $(use_enable static-libs static)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ emake -j1 check
+}
+
+src_install() {
+ local DOCS=( ChangeLog )
+ use doc && local HTML_DOCS=( doc/relp.html )
+ default
+
+ find "${ED}"usr/lib* -name '*.la' -delete || die
+}