summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2019-11-03 13:40:42 -0700
committerDenis Dupeyron <calchan@gentoo.org>2019-11-03 13:41:14 -0700
commit0f2814561f6750e9d9c1d93d9538934b60bdc0cb (patch)
treed0be18d00b8d6e6bfc9b34284b0f77a831f6d697 /dev-libs
parentdev-ada/asis: Remove dependency on dev-ada/gnatcoll (diff)
downloadgentoo-0f2814561f6750e9d9c1d93d9538934b60bdc0cb.tar.gz
gentoo-0f2814561f6750e9d9c1d93d9538934b60bdc0cb.tar.bz2
gentoo-0f2814561f6750e9d9c1d93d9538934b60bdc0cb.zip
dev-libs/libstroke: update to EAPI 7
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Denis Dupeyron <calchan@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libstroke/libstroke-0.5.1-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/libstroke/libstroke-0.5.1-r1.ebuild b/dev-libs/libstroke/libstroke-0.5.1-r1.ebuild
new file mode 100644
index 000000000000..983798ae2254
--- /dev/null
+++ b/dev-libs/libstroke/libstroke-0.5.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils autotools
+
+DESCRIPTION="A Stroke and Gesture recognition Library"
+HOMEPAGE="http://www.etla.net/libstroke/"
+SRC_URI="http://www.etla.net/libstroke/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11"
+DEPEND="x11-base/xorg-proto
+ ${RDEPEND}"
+
+src_prepare() {
+ eapply "${FILESDIR}"/${P}-m4_syntax.patch
+ eapply "${FILESDIR}"/${P}-no_gtk1.patch
+ eapply "${FILESDIR}"/${P}-autotools.patch
+ eapply_user
+ eautoreconf
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die
+ dodoc CREDITS ChangeLog README
+}