summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-01-03 15:49:06 +0100
committerDavid Seifert <soap@gentoo.org>2023-01-03 15:49:06 +0100
commit128c4b0b6c73f994174bf351d311ed021adbc6f7 (patch)
treeb29ea0b846a53af1bc54ded701368dd2ff5f638a /dev-libs
parentwww-apps/prowlarr: drop 1.0.0.2171 (diff)
downloadgentoo-128c4b0b6c73f994174bf351d311ed021adbc6f7.tar.gz
gentoo-128c4b0b6c73f994174bf351d311ed021adbc6f7.tar.bz2
gentoo-128c4b0b6c73f994174bf351d311ed021adbc6f7.zip
*/*: make mycmakeargs local
Closes: https://github.com/gentoo/gentoo/pull/28947 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/asmjit/asmjit-2021.11.13.ebuild4
-rw-r--r--dev-libs/asmjit/asmjit-2022.07.02.ebuild4
-rw-r--r--dev-libs/libcbor/libcbor-0.9.0.ebuild4
-rw-r--r--dev-libs/libgaminggear/libgaminggear-0.15.1.ebuild27
-rw-r--r--dev-libs/rocksdb/rocksdb-6.14.6-r1.ebuild4
-rw-r--r--dev-libs/rocksdb/rocksdb-6.15.5.ebuild4
-rw-r--r--dev-libs/rocksdb/rocksdb-6.17.3.ebuild4
-rw-r--r--dev-libs/simdjson/simdjson-1.0.2.ebuild4
-rw-r--r--dev-libs/simdjson/simdjson-1.1.0.ebuild4
-rw-r--r--dev-libs/simdjson/simdjson-2.0.4.ebuild4
-rw-r--r--dev-libs/simdjson/simdjson-2.1.0-r1.ebuild4
-rw-r--r--dev-libs/simdjson/simdjson-2.2.2.ebuild4
-rw-r--r--dev-libs/simdjson/simdjson-3.0.0.ebuild4
-rw-r--r--dev-libs/thrift/thrift-0.16.0-r1.ebuild4
14 files changed, 29 insertions, 50 deletions
diff --git a/dev-libs/asmjit/asmjit-2021.11.13.ebuild b/dev-libs/asmjit/asmjit-2021.11.13.ebuild
index 27da2e68b8b3..95281b54c698 100644
--- a/dev-libs/asmjit/asmjit-2021.11.13.ebuild
+++ b/dev-libs/asmjit/asmjit-2021.11.13.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022 Gentoo Authors
+# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -27,7 +27,7 @@ PATCHES=(
)
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DASMJIT_TEST=$(usex test TRUE FALSE)
)
cmake_src_configure
diff --git a/dev-libs/asmjit/asmjit-2022.07.02.ebuild b/dev-libs/asmjit/asmjit-2022.07.02.ebuild
index 909111795e67..a436e9b2a3f1 100644
--- a/dev-libs/asmjit/asmjit-2022.07.02.ebuild
+++ b/dev-libs/asmjit/asmjit-2022.07.02.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022 Gentoo Authors
+# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -23,7 +23,7 @@ RESTRICT="!test? ( test )"
S="${WORKDIR}"/${PN}-${CommitId}
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DASMJIT_TEST=$(usex test)
)
cmake_src_configure
diff --git a/dev-libs/libcbor/libcbor-0.9.0.ebuild b/dev-libs/libcbor/libcbor-0.9.0.ebuild
index 9d2172da0ce8..44cb6de4d07c 100644
--- a/dev-libs/libcbor/libcbor-0.9.0.ebuild
+++ b/dev-libs/libcbor/libcbor-0.9.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020-2022 Gentoo Authors
+# Copyright 2020-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -40,7 +40,7 @@ pkg_setup() {
}
src_configure() {
- local -a mycmakeargs=(
+ local mycmakeargs=(
-DCMAKE_BUILD_TYPE=Release
-DCBOR_CUSTOM_ALLOC=$(usex custom-alloc 'ON' 'OFF')
-DWITH_TESTS=$(usex test 'ON' 'OFF')
diff --git a/dev-libs/libgaminggear/libgaminggear-0.15.1.ebuild b/dev-libs/libgaminggear/libgaminggear-0.15.1.ebuild
index d840aa57f738..2a564652addf 100644
--- a/dev-libs/libgaminggear/libgaminggear-0.15.1.ebuild
+++ b/dev-libs/libgaminggear/libgaminggear-0.15.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake xdg
+inherit xdg cmake
DESCRIPTION="Provides functionality for gaming input devices"
@@ -39,30 +39,9 @@ PATCHES=(
"${FILESDIR}"/${P}-cmake-3.13.patch
)
-# Required because xdg.eclass overrides src_prepare() from cmake.eclass
-src_prepare() {
- cmake_src_prepare
-}
-
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DWITH_DOC="$(usex doc)"
)
cmake_src_configure
}
-
-src_install() {
- cmake_src_install
-}
-
-pkg_preinst() {
- xdg_pkg_preinst
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-}
-
-pkg_postrm() {
- xdg_pkg_postrm
-}
diff --git a/dev-libs/rocksdb/rocksdb-6.14.6-r1.ebuild b/dev-libs/rocksdb/rocksdb-6.14.6-r1.ebuild
index 3ec9e9aee852..aff46d621617 100644
--- a/dev-libs/rocksdb/rocksdb-6.14.6-r1.ebuild
+++ b/dev-libs/rocksdb/rocksdb-6.14.6-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020-2022 Gentoo Authors
+# Copyright 2020-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -30,7 +30,7 @@ PATCHES=(
)
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DFAIL_ON_WARNINGS=OFF
-DFORCE_AVX2=$(usex cpu_flags_x86_avx2 ON OFF)
-DFORCE_AVX=$(usex cpu_flags_x86_avx ON OFF)
diff --git a/dev-libs/rocksdb/rocksdb-6.15.5.ebuild b/dev-libs/rocksdb/rocksdb-6.15.5.ebuild
index cb835069c451..adeb2e8a46e8 100644
--- a/dev-libs/rocksdb/rocksdb-6.15.5.ebuild
+++ b/dev-libs/rocksdb/rocksdb-6.15.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020-2022 Gentoo Authors
+# Copyright 2020-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -30,7 +30,7 @@ PATCHES=(
)
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DFAIL_ON_WARNINGS=OFF
-DFORCE_AVX2=$(usex cpu_flags_x86_avx2 ON OFF)
-DFORCE_AVX=$(usex cpu_flags_x86_avx ON OFF)
diff --git a/dev-libs/rocksdb/rocksdb-6.17.3.ebuild b/dev-libs/rocksdb/rocksdb-6.17.3.ebuild
index ce510723b0dd..8da4d0066c99 100644
--- a/dev-libs/rocksdb/rocksdb-6.17.3.ebuild
+++ b/dev-libs/rocksdb/rocksdb-6.17.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020-2022 Gentoo Authors
+# Copyright 2020-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -31,7 +31,7 @@ PATCHES=(
)
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DFAIL_ON_WARNINGS=OFF
-DFORCE_AVX2=$(usex cpu_flags_x86_avx2 ON OFF)
-DFORCE_AVX=$(usex cpu_flags_x86_avx ON OFF)
diff --git a/dev-libs/simdjson/simdjson-1.0.2.ebuild b/dev-libs/simdjson/simdjson-1.0.2.ebuild
index 71e7e89153e9..e4fbf9055959 100644
--- a/dev-libs/simdjson/simdjson-1.0.2.ebuild
+++ b/dev-libs/simdjson/simdjson-1.0.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020-2022 Gentoo Authors
+# Copyright 2020-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -60,7 +60,7 @@ src_prepare() {
}
src_configure() {
- local -a mycmakeargs=(
+ local mycmakeargs=(
-DSIMDJSON_ENABLE_THREADS=ON
)
use test && mycmakeargs+=(
diff --git a/dev-libs/simdjson/simdjson-1.1.0.ebuild b/dev-libs/simdjson/simdjson-1.1.0.ebuild
index 6f9106ac1e38..65bd48189585 100644
--- a/dev-libs/simdjson/simdjson-1.1.0.ebuild
+++ b/dev-libs/simdjson/simdjson-1.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020-2022 Gentoo Authors
+# Copyright 2020-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -60,7 +60,7 @@ src_prepare() {
}
src_configure() {
- local -a mycmakeargs=(
+ local mycmakeargs=(
-DSIMDJSON_ENABLE_THREADS=ON
)
use test && mycmakeargs+=(
diff --git a/dev-libs/simdjson/simdjson-2.0.4.ebuild b/dev-libs/simdjson/simdjson-2.0.4.ebuild
index b8e15288e648..e10cd8aa1dc0 100644
--- a/dev-libs/simdjson/simdjson-2.0.4.ebuild
+++ b/dev-libs/simdjson/simdjson-2.0.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020-2022 Gentoo Authors
+# Copyright 2020-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -60,7 +60,7 @@ src_prepare() {
}
src_configure() {
- local -a mycmakeargs=(
+ local mycmakeargs=(
-DSIMDJSON_ENABLE_THREADS=ON
)
use test && mycmakeargs+=(
diff --git a/dev-libs/simdjson/simdjson-2.1.0-r1.ebuild b/dev-libs/simdjson/simdjson-2.1.0-r1.ebuild
index 55fc98496a4e..a0cc3eba3666 100644
--- a/dev-libs/simdjson/simdjson-2.1.0-r1.ebuild
+++ b/dev-libs/simdjson/simdjson-2.1.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020-2022 Gentoo Authors
+# Copyright 2020-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -60,7 +60,7 @@ src_prepare() {
}
src_configure() {
- local -a mycmakeargs=(
+ local mycmakeargs=(
-DSIMDJSON_ENABLE_THREADS=ON
)
use test && mycmakeargs+=(
diff --git a/dev-libs/simdjson/simdjson-2.2.2.ebuild b/dev-libs/simdjson/simdjson-2.2.2.ebuild
index 976892c2f0c0..39d05eeab9e9 100644
--- a/dev-libs/simdjson/simdjson-2.2.2.ebuild
+++ b/dev-libs/simdjson/simdjson-2.2.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020-2022 Gentoo Authors
+# Copyright 2020-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -61,7 +61,7 @@ src_prepare() {
}
src_configure() {
- local -a mycmakeargs=(
+ local mycmakeargs=(
-DSIMDJSON_ENABLE_THREADS=ON
)
use test && mycmakeargs+=(
diff --git a/dev-libs/simdjson/simdjson-3.0.0.ebuild b/dev-libs/simdjson/simdjson-3.0.0.ebuild
index cac6dd3f9eba..96531492db42 100644
--- a/dev-libs/simdjson/simdjson-3.0.0.ebuild
+++ b/dev-libs/simdjson/simdjson-3.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020-2022 Gentoo Authors
+# Copyright 2020-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -62,7 +62,7 @@ src_prepare() {
}
src_configure() {
- local -a mycmakeargs=(
+ local mycmakeargs=(
-DSIMDJSON_ENABLE_THREADS=ON
)
use test && mycmakeargs+=(
diff --git a/dev-libs/thrift/thrift-0.16.0-r1.ebuild b/dev-libs/thrift/thrift-0.16.0-r1.ebuild
index d4db37319da1..22f3fc9e88b4 100644
--- a/dev-libs/thrift/thrift-0.16.0-r1.ebuild
+++ b/dev-libs/thrift/thrift-0.16.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022 Gentoo Authors
+# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -33,7 +33,7 @@ PATCHES=(
)
src_configure() {
- local -a mycmakeargs=(
+ local mycmakeargs=(
-DBUILD_CPP=ON
-DBUILD_C_GLIB=OFF
-DBUILD_JAVA=OFF