summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-10-10 18:15:37 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-10-10 18:16:08 +0200
commit198fbc1358474f003a47dd46bd389970262a2621 (patch)
treec626f7c4bdbb6a6467b96fb6e19c84a10a43b004 /dev-libs
parentmail-client/kube: Fix metainfo installation path (diff)
downloadgentoo-198fbc1358474f003a47dd46bd389970262a2621.tar.gz
gentoo-198fbc1358474f003a47dd46bd389970262a2621.tar.bz2
gentoo-198fbc1358474f003a47dd46bd389970262a2621.zip
dev-libs/mxml: bump to version 3.2
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/mxml/Manifest1
-rw-r--r--dev-libs/mxml/mxml-3.2.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-libs/mxml/Manifest b/dev-libs/mxml/Manifest
index 1558e0e60483..ff44384f5f2c 100644
--- a/dev-libs/mxml/Manifest
+++ b/dev-libs/mxml/Manifest
@@ -1 +1,2 @@
DIST mxml-3.1.tar.gz 9267206 BLAKE2B d5cee24804978b474bf5b58c7a5932b50d7197a35e65da20c2517ce7db01d22027449348d6b15ddf0d186219ac81993055deaa4af9f48439273f8d2d74b27edd SHA512 8f8923b394093db5c471c52c17185916bc3c91f66c97de66919bfef2a09f271879a52f285e5fc4ded03484a3f83ba8fdb588d985b06e0c25ee001f1a80ffa586
+DIST mxml-3.2.tar.gz 9267930 BLAKE2B f244dab599233b8a26aba5a11526979bf2f4d20b5fce67858f7759abc5bd2f3e2aac19d512c887248839d130cf1314065687cd1ccf91edbf5533ae2d342f286b SHA512 ed3f2b361394ef225a708b0032976a3d191d5eaea3022e190b29e0ee140e8f998f1d65c64e4898872b169516cee44f4f5f18401c6410c3b5aa1e9680b23e8675
diff --git a/dev-libs/mxml/mxml-3.2.ebuild b/dev-libs/mxml/mxml-3.2.ebuild
new file mode 100644
index 000000000000..e4fccf7d1f76
--- /dev/null
+++ b/dev-libs/mxml/mxml-3.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="A small XML parsing library that you can use to read XML data files or strings"
+HOMEPAGE="
+ https://github.com/michaelrsweet/mxml
+ https://www.msweet.org/mxml/
+"
+SRC_URI="https://github.com/michaelrsweet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Mini-XML"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static-libs threads"
+
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # Respect users CFLAGS
+ sed -e 's/-Os -g//' -i configure.ac || die
+
+ # Don't run always tests
+ # Enable verbose compiling
+ sed -e '/ALLTARGETS/s/testmxml//g' -e '/.SILENT:/d' -i Makefile.in || die
+
+ # Build only static-libs, when requested by user, also build docs without static-libs in that case
+ if ! use static-libs; then
+ local mysedopts=(
+ -e '/^install:/s/install-libmxml.a//g'
+ -e '/^mxml.xml:/s/-static//g'
+ -e '/^mxml.epub:/s/-static//g'
+ -e '/^valgrind/s/-static//g'
+ -e 's/.\/mxmldoc-static/LD_LIBRARY_PATH="." .\/mxmldoc/g'
+ )
+ sed "${mysedopts[@]}" -i Makefile.in || die
+ fi
+
+ eautoconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable threads)
+ --with-docdir=/usr/share/doc/"${PF}"
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ emake testmxml
+}
+
+src_install() {
+ emake DSTROOT="${ED}" install
+}