summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Zero <zero-one@zer0-one.net>2021-09-23 01:00:41 -0400
committerSam James <sam@gentoo.org>2021-09-25 20:07:42 +0100
commit1f3776d1d8f7b1cbd8664024e2a062d48f6274ce (patch)
tree22ab59aa69107039b0f7ab18fe731c0317bcb0a0 /dev-libs
parentgames-engines/scummvm: keyword 2.2.0-r2 for ~riscv (diff)
downloadgentoo-1f3776d1d8f7b1cbd8664024e2a062d48f6274ce.tar.gz
gentoo-1f3776d1d8f7b1cbd8664024e2a062d48f6274ce.tar.bz2
gentoo-1f3776d1d8f7b1cbd8664024e2a062d48f6274ce.zip
dev-libs/jansson: version bump to 2.14
Also bumps EAPI to 8, and removes the sphinx patch. Closes: https://bugs.gentoo.org/812119 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: David Zero <zero-one@zer0-one.net> Closes: https://github.com/gentoo/gentoo/pull/22368 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/jansson/Manifest1
-rw-r--r--dev-libs/jansson/jansson-2.14.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/jansson/Manifest b/dev-libs/jansson/Manifest
index e447cfce78ed..8d590df3b22b 100644
--- a/dev-libs/jansson/Manifest
+++ b/dev-libs/jansson/Manifest
@@ -1 +1,2 @@
DIST jansson-2.13.1.tar.gz 531924 BLAKE2B e627bd2ba69bf01b053ff13dee903056db86999f774d6863517e67cef7dc9ddcaa747f2edca9de86bd83f37940a394ac9907f7d58069607ee529af08d8514d57 SHA512 e32be6665e41cf1763608c2f1ac4ce0824d4d7ffa5f4a5824cefde279250fdd399d49ba93d8894e16a473731f629b846554654347f027ca9a0a96ed047f10192
+DIST jansson-2.14.tar.gz 535618 BLAKE2B eb514ff222444d4c0d1ef6b99150e3e43bd4d7a1bec3d66e5ece8bc59ac19a0898d9eb061cacad52afda7fe172ec6df46b5a90952707422f56daae53f82c9427 SHA512 5a592776c7ba8c0b1f5efaf813f77948bbc4bda168a72d221d176af0cf61038e26c1f30795433be10e2fc5069d5763d11852a8574774906a9f8ad261ac30109c
diff --git a/dev-libs/jansson/jansson-2.14.ebuild b/dev-libs/jansson/jansson-2.14.ebuild
new file mode 100644
index 000000000000..28cc3b9bc422
--- /dev/null
+++ b/dev-libs/jansson/jansson-2.14.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal
+
+DESCRIPTION="C library for encoding, decoding and manipulating JSON data"
+HOMEPAGE="https://www.digip.org/jansson/"
+SRC_URI="https://github.com/akheron/jansson/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/4"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="doc static-libs"
+
+BDEPEND="doc? ( dev-python/sphinx )"
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
+}
+
+multilib_src_compile() {
+ default
+
+ if multilib_is_native_abi && use doc ; then
+ emake html
+ HTML_DOCS=( "${BUILD_DIR}"/doc/_build/html/. )
+ fi
+}
+
+multilib_src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}