summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-02-26 03:31:03 +0000
committerSam James <sam@gentoo.org>2022-02-26 03:43:16 +0000
commit1f84084525a30acbef4a0ec78c6aef40433cd3e8 (patch)
tree98132b3e391fc948eb21e8d51fc36e382750588a /dev-libs
parentdev-libs/libvterm: add 0.1.4 (diff)
downloadgentoo-1f84084525a30acbef4a0ec78c6aef40433cd3e8.tar.gz
gentoo-1f84084525a30acbef4a0ec78c6aef40433cd3e8.tar.bz2
gentoo-1f84084525a30acbef4a0ec78c6aef40433cd3e8.zip
dev-libs/libvterm: add 0.2 (unkeyworded)
Unkeyworded given there's a patch Fedora are using to revert a commit and I'd rather wait and see if upstream do a new release or not, but it's here for people to test with anyway. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libvterm/Manifest1
-rw-r--r--dev-libs/libvterm/libvterm-0.2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-libs/libvterm/Manifest b/dev-libs/libvterm/Manifest
index d73b92f1ed03..ae29c865b06d 100644
--- a/dev-libs/libvterm/Manifest
+++ b/dev-libs/libvterm/Manifest
@@ -3,3 +3,4 @@ DIST libvterm-0.1.1.tar.gz 69044 BLAKE2B 2e521a26238772370718e3c643e2225c9be7877
DIST libvterm-0.1.2.tar.gz 69050 BLAKE2B bd547e14ef2b2b7c733a88ccd975db5ccc936ad5df49221cc6877be223e48da41fd8e5cf40dbc8750a95d6efaa6e5b97d337d4a013ec534a4bbfd68279325bc0 SHA512 5d6a17b98d4dda9d0529c3686cadc1f788e48667fa133100bfb0cdc92a6b08d0ea2f1a6058f58941e1408788c4f1d5a86941ec2457e31c6582f5ddd13bcdf7c4
DIST libvterm-0.1.3.tar.gz 69115 BLAKE2B befdb173a75652a42f3ba72682cc5c411ee170f2cfe46a22f133ca2b414f40f3af97331a4aaa34ca2a36f39b2ef92b63f2730bd872db8181512fd18f95921034 SHA512 de68b36c589638cc727fdd8153af66cc9288d32567bca1213e3769418a7b98afff68565dfd34f73f74625c39e66b60da7e658e9afa9bef4efa2072ff91d872e5
DIST libvterm-0.1.4.tar.gz 69122 BLAKE2B 4f0acc9ec6755c4a840e5df6c32c44e12c5316b5c5918d0e8eada19d819736c3e5b9090b468e32b3141a7fbb5ba226e365be27d6d1d9ca22f9f5e365fc3971c2 SHA512 90b5d47417e3f469df5c6574a27d12bd6bd1571d17cab7c4ac0ee61b1dbcb6361987f6fdfd11e314ea32f8958ec165c319a34d0f77288947c7cbc11de697d524
+DIST libvterm-0.2.tar.gz 79712 BLAKE2B db17d15550a595652368edd7ee0ccab2a69effa79677a23d6ee94731fc05d685df0de843d2e953cd59d2077922e72834d7ab09eaf5260aed869d9511cfd224a7 SHA512 bc99ae4fbdc165ced92c10fb0168ae6da2ed702208064616fefcd42aba71c57b7d42a08bc5b0e7e1ebda8cc4b5682d16059bdd2edfb12fbd8ac97527e854b14c
diff --git a/dev-libs/libvterm/libvterm-0.2.ebuild b/dev-libs/libvterm/libvterm-0.2.ebuild
new file mode 100644
index 000000000000..84e1e689e51e
--- /dev/null
+++ b/dev-libs/libvterm/libvterm-0.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="An abstract library implementation of a VT220/xterm/ECMA-48 terminal emulator"
+HOMEPAGE="https://www.leonerd.org.uk/code/libvterm/"
+SRC_URI="https://www.leonerd.org.uk/code/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+# Fedora have a revert patch for now:
+# https://src.fedoraproject.org/rpms/libvterm/blob/rawhide/f/libvterm-0.2-fix-resize-buffer.patch
+# so let's see if 0.2.1 is any better or if this is actually needed for us?
+#KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~x64-macos"
+
+BDEPEND="
+ dev-lang/perl
+ sys-devel/libtool
+ virtual/pkgconfig
+"
+RDEPEND="!dev-libs/libvterm-neovim"
+
+src_compile() {
+ tc-export CC
+
+ append-cflags -fPIC
+ emake VERBOSE=1 PREFIX="${EPREFIX}/usr" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}
+
+src_install() {
+ emake \
+ VERBOSE=1 \
+ PREFIX="${EPREFIX}/usr" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ DESTDIR="${D}" install
+
+ find "${ED}" -name '*.la' -delete || die "Failed to prune libtool files"
+}