summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2018-05-17 14:04:05 +0300
committerSergey Popov <pinkbyte@gentoo.org>2018-05-17 14:04:05 +0300
commit243c165bcfd4bf25c727200fc1cf503a5148933a (patch)
treea259108d2708261bc4acb83edea796198e8cb3dc /dev-libs
parentdev-libs/libx86-1.1-r4: stable on amd64 and x86 (diff)
downloadgentoo-243c165bcfd4bf25c727200fc1cf503a5148933a.tar.gz
gentoo-243c165bcfd4bf25c727200fc1cf503a5148933a.tar.bz2
gentoo-243c165bcfd4bf25c727200fc1cf503a5148933a.zip
dev-libs/libx86: drop old
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libx86/libx86-1.1-r2.ebuild36
-rw-r--r--dev-libs/libx86/libx86-1.1-r3.ebuild46
2 files changed, 0 insertions, 82 deletions
diff --git a/dev-libs/libx86/libx86-1.1-r2.ebuild b/dev-libs/libx86/libx86-1.1-r2.ebuild
deleted file mode 100644
index 72c2285dadff..000000000000
--- a/dev-libs/libx86/libx86-1.1-r2.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils multilib toolchain-funcs
-
-DESCRIPTION="A hardware-independent library for executing real-mode x86 code"
-HOMEPAGE="http://www.codon.org.uk/~mjg59/libx86"
-SRC_URI="http://www.codon.org.uk/~mjg59/${PN}/downloads/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-src_prepare() {
- # fix compile failure with linux-headers-2.6.26, bug 235599
- epatch "${FILESDIR}"/${PN}-0.99-ifmask.patch
- sed -i 's:\($(CC) $(CFLAGS)\)\( -o libx86.so.1\):\1 $(LDFLAGS)\2:' \
- Makefile || die #236888
- tc-export CC AR
-}
-
-src_compile() {
- local ARGS
- use amd64 && ARGS="BACKEND=x86emu"
- emake ${ARGS}
-}
-
-src_install() {
- emake \
- LIBDIR="/usr/$(get_libdir)" \
- DESTDIR="${D}" \
- install
-}
diff --git a/dev-libs/libx86/libx86-1.1-r3.ebuild b/dev-libs/libx86/libx86-1.1-r3.ebuild
deleted file mode 100644
index 7bc72dd56ee3..000000000000
--- a/dev-libs/libx86/libx86-1.1-r3.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils multilib toolchain-funcs flag-o-matic
-
-DESCRIPTION="A hardware-independent library for executing real-mode x86 code"
-HOMEPAGE="http://www.codon.org.uk/~mjg59/libx86"
-SRC_URI="http://www.codon.org.uk/~mjg59/${PN}/downloads/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="static-libs"
-
-src_prepare() {
- # fix compile failure with linux-headers-2.6.26, bug 235599
- epatch "${FILESDIR}"/${PN}-0.99-ifmask.patch
- # Patch for bugs #236888 and #456648
- epatch "${FILESDIR}"/${P}-makefile.patch
-}
-
-src_configure() {
- tc-export CC AR
- append-flags -fno-delete-null-pointer-checks #523276
-}
-
-src_compile() {
- local ARGS
- use amd64 && ARGS="BACKEND=x86emu"
- emake ${ARGS} LIBRARY=shared shared
- if use static-libs; then
- emake ${ARGS} objclean
- emake ${ARGS} LIBRARY=static static
- fi
-}
-
-src_install() {
- local install_static;
- use static-libs && install_static='install-static'
- emake \
- LIBDIR="/usr/$(get_libdir)" \
- DESTDIR="${D}" \
- install-header install-shared ${install_static}
-}