summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-02 04:37:39 +0100
committerSam James <sam@gentoo.org>2022-04-02 04:44:28 +0100
commit2acd2e6971c4ada4fa618474483025856a815df0 (patch)
tree54197ce7aa1548443e3a99d6c7cfbbb032ea93a8 /dev-libs
parentdev-libs/libxml2: add 9999 (diff)
downloadgentoo-2acd2e6971c4ada4fa618474483025856a815df0.tar.gz
gentoo-2acd2e6971c4ada4fa618474483025856a815df0.tar.bz2
gentoo-2acd2e6971c4ada4fa618474483025856a815df0.zip
dev-libs/libxml2: use live template
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libxml2/libxml2-2.9.13-r1.ebuild24
-rw-r--r--dev-libs/libxml2/libxml2-9999.ebuild21
2 files changed, 35 insertions, 10 deletions
diff --git a/dev-libs/libxml2/libxml2-2.9.13-r1.ebuild b/dev-libs/libxml2/libxml2-2.9.13-r1.ebuild
index 5d7a300bba44..4789bc568a0a 100644
--- a/dev-libs/libxml2/libxml2-2.9.13-r1.ebuild
+++ b/dev-libs/libxml2/libxml2-2.9.13-r1.ebuild
@@ -9,7 +9,7 @@ PATCHSET_VERSION="2.9.12-r5-patchset"
PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="xml"
-inherit autotools flag-o-matic gnome.org prefix python-r1 multilib-minimal
+inherit autotools flag-o-matic prefix python-r1 multilib-minimal
XSTS_HOME="http://www.w3.org/XML/2004/xml-schema-test-suite"
XSTS_NAME_1="xmlschema2002-01-16"
@@ -19,14 +19,20 @@ XSTS_TARBALL_2="xsts-2004-01-14.tar.gz"
XMLCONF_TARBALL="xmlts20130923.tar.gz"
DESCRIPTION="XML C parser and toolkit"
HOMEPAGE="http://www.xmlsoft.org/ https://gitlab.gnome.org/GNOME/libxml2"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/libxml2"
+ inherit git-r3
+else
+ inherit gnome.org
+ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
SRC_URI+="
https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${PN}-${PATCHSET_VERSION}.tar.bz2
test? (
${XSTS_HOME}/${XSTS_NAME_1}/${XSTS_TARBALL_1}
${XSTS_HOME}/${XSTS_NAME_2}/${XSTS_TARBALL_2}
https://www.w3.org/XML/Test/${XMLCONF_TARBALL}
- )
-"
+ )"
S="${WORKDIR}/${PN}-${PV%_rc*}"
LICENSE="MIT"
@@ -75,11 +81,15 @@ PATCHES=(
)
src_unpack() {
- local tarname=${P/_rc/-rc}.tar.xz
+ if [[ ${PV} == 9999 ]] ; then
+ git-r3_src_unpack
+ else
+ local tarname=${P/_rc/-rc}.tar.xz
- # ${A} isn't used to avoid unpacking of test tarballs into ${WORKDIR},
- # as they are needed as tarballs in ${S}/xstc instead and not unpacked
- unpack ${tarname} ${PN}-${PATCHSET_VERSION}.tar.bz2
+ # ${A} isn't used to avoid unpacking of test tarballs into ${WORKDIR},
+ # as they are needed as tarballs in ${S}/xstc instead and not unpacked
+ unpack ${tarname} ${PN}-${PATCHSET_VERSION}.tar.bz2
+ fi
cd "${S}" || die
diff --git a/dev-libs/libxml2/libxml2-9999.ebuild b/dev-libs/libxml2/libxml2-9999.ebuild
index 18743bea1507..3ad0604b6f1e 100644
--- a/dev-libs/libxml2/libxml2-9999.ebuild
+++ b/dev-libs/libxml2/libxml2-9999.ebuild
@@ -7,8 +7,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="xml"
-EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/libxml2"
-inherit autotools flag-o-matic python-r1 multilib-minimal git-r3
+inherit autotools flag-o-matic python-r1 multilib-minimal
XSTS_HOME="http://www.w3.org/XML/2004/xml-schema-test-suite"
XSTS_NAME_1="xmlschema2002-01-16"
@@ -19,6 +18,14 @@ XMLCONF_TARBALL="xmlts20130923.tar.gz"
DESCRIPTION="XML C parser and toolkit"
HOMEPAGE="http://www.xmlsoft.org/ https://gitlab.gnome.org/GNOME/libxml2"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/libxml2"
+ inherit git-r3
+else
+ inherit gnome.org
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
SRC_URI+="
test? (
${XSTS_HOME}/${XSTS_NAME_1}/${XSTS_TARBALL_1}
@@ -53,7 +60,15 @@ MULTILIB_CHOST_TOOLS=(
DOCS=( NEWS README.md TODO TODO_SCHEMAS python/TODO )
src_unpack() {
- git-r3_src_unpack
+ if [[ ${PV} == 9999 ]] ; then
+ git-r3_src_unpack
+ else
+ local tarname=${P/_rc/-rc}.tar.xz
+
+ # ${A} isn't used to avoid unpacking of test tarballs into ${WORKDIR},
+ # as they are needed as tarballs in ${S}/xstc instead and not unpacked
+ unpack ${tarname} ${PN}-${PATCHSET_VERSION}.tar.bz2
+ fi
cd "${S}" || die