summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2022-10-02 08:53:16 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2022-10-02 08:53:20 +0200
commit2dbcdb762dc56dfbb614b571a44d3f93bca79294 (patch)
tree577d2623469886e479e1f73359ceae2d16bf2448 /dev-libs
parentdev-ruby/unicode-display_width: add 2.3.0 (diff)
downloadgentoo-2dbcdb762dc56dfbb614b571a44d3f93bca79294.tar.gz
gentoo-2dbcdb762dc56dfbb614b571a44d3f93bca79294.tar.bz2
gentoo-2dbcdb762dc56dfbb614b571a44d3f93bca79294.zip
dev-libs/sord: bump to 0.16.14 + updated homepage & dropped python eclass
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/sord/Manifest1
-rw-r--r--dev-libs/sord/sord-0.16.12-r1.ebuild6
-rw-r--r--dev-libs/sord/sord-0.16.14.ebuild56
-rw-r--r--dev-libs/sord/sord-9999.ebuild6
4 files changed, 61 insertions, 8 deletions
diff --git a/dev-libs/sord/Manifest b/dev-libs/sord/Manifest
index 5472d8bcb126..979bb5fe226d 100644
--- a/dev-libs/sord/Manifest
+++ b/dev-libs/sord/Manifest
@@ -1 +1,2 @@
DIST sord-0.16.12.tar.xz 111328 BLAKE2B 9b89848440a994145a934e66e6fe7b844e82e926cb48d05223faef9357d315db981cd68b1174d7c47e5d63b97f8e15d8cc6b2b992a6bd790b8b117ebbb6c059a SHA512 d63cc1473d12676dac3724a096c85fd47745e456cf4b191fd9f8aaf8bb9399510c6878948fd045cc1942356e61dbefd8d88374c1ef6b327057e0bb8bfa03f926
+DIST sord-0.16.14.tar.xz 112748 BLAKE2B 399f4bf5d1b8ae557fa7e2d2e92e74ed646d0554235f4527a4b9ad53aa6beb0e90e2d80c9e65ab3c872b5c8d45a7948b7746284bb1fd2352320a0aa33e97e305 SHA512 f6f254518d5dccece7975529b1fcfd552fd9c37e49dc7e9f8a46756b85e476dac064a39af42bfb3078e999e75d1aa75dcc30ec91e08753defa9363adafdfd3bd
diff --git a/dev-libs/sord/sord-0.16.12-r1.ebuild b/dev-libs/sord/sord-0.16.12-r1.ebuild
index 77c7d61955dd..b27f7b6398a4 100644
--- a/dev-libs/sord/sord-0.16.12-r1.ebuild
+++ b/dev-libs/sord/sord-0.16.12-r1.ebuild
@@ -3,9 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..11} )
-PYTHON_REQ_USE='threads(+)'
-inherit meson-multilib python-any-r1
+inherit meson-multilib
if [[ ${PV} == 9999 ]]; then
inherit git-r3
@@ -16,7 +14,7 @@ else
fi
DESCRIPTION="Library for storing RDF data in memory"
-HOMEPAGE="http://drobilla.net/software/sord/"
+HOMEPAGE="https://drobilla.net/software/sord.html"
LICENSE="ISC"
SLOT="0"
diff --git a/dev-libs/sord/sord-0.16.14.ebuild b/dev-libs/sord/sord-0.16.14.ebuild
new file mode 100644
index 000000000000..bdc36cd5811a
--- /dev/null
+++ b/dev-libs/sord/sord-0.16.14.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson-multilib
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/drobilla/sord.git"
+else
+ SRC_URI="http://download.drobilla.net/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+DESCRIPTION="Library for storing RDF data in memory"
+HOMEPAGE="https://drobilla.net/software/sord.html"
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="doc test tools"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+RDEPEND="
+ dev-libs/libpcre
+ dev-libs/serd
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+"
+
+src_prepare() {
+ default
+
+ # fix doc installation path
+ sed -i "s/versioned_name/'${PF}'/g" doc/meson.build || die
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_native_use_feature doc docs)
+ $(meson_feature test tests)
+ $(meson_feature tools)
+ )
+
+ meson_src_configure
+}
+
+multilib_src_install_all() {
+ local DOCS=( AUTHORS NEWS README.md )
+ einstalldocs
+}
diff --git a/dev-libs/sord/sord-9999.ebuild b/dev-libs/sord/sord-9999.ebuild
index 02f84963e6bd..bdc36cd5811a 100644
--- a/dev-libs/sord/sord-9999.ebuild
+++ b/dev-libs/sord/sord-9999.ebuild
@@ -3,9 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..11} )
-PYTHON_REQ_USE='threads(+)'
-inherit meson-multilib python-any-r1
+inherit meson-multilib
if [[ ${PV} == 9999 ]]; then
inherit git-r3
@@ -16,7 +14,7 @@ else
fi
DESCRIPTION="Library for storing RDF data in memory"
-HOMEPAGE="http://drobilla.net/software/sord/"
+HOMEPAGE="https://drobilla.net/software/sord.html"
LICENSE="ISC"
SLOT="0"