summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2018-08-16 12:04:38 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-08-20 00:50:41 +0200
commit325269625ca7d5d8a166eeb46a56ea712033c336 (patch)
tree26ba5424fdaff3eab71ba74b4257b9124e9b22c5 /dev-libs
parentsys-kernel/rt-sources: remove old. (diff)
downloadgentoo-325269625ca7d5d8a166eeb46a56ea712033c336.tar.gz
gentoo-325269625ca7d5d8a166eeb46a56ea712033c336.tar.bz2
gentoo-325269625ca7d5d8a166eeb46a56ea712033c336.zip
dev-libs/spdlog: verbump to 1.1.0.
Closes: https://github.com/gentoo/gentoo/pull/9589
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/spdlog/Manifest1
-rw-r--r--dev-libs/spdlog/spdlog-1.1.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/spdlog/Manifest b/dev-libs/spdlog/Manifest
index 2291d1dbf3b8..b8ec66bb7db2 100644
--- a/dev-libs/spdlog/Manifest
+++ b/dev-libs/spdlog/Manifest
@@ -1,2 +1,3 @@
DIST spdlog-0.17.0.tar.gz 172323 BLAKE2B 2ca821fb3da0ee82601dd9ef54ca155ffdf19ea1e51c6fbb7269a58bf7a662b5225c9ef7e4d8ccbe7a05c56aeefaad27ddc9cfe21a329f52490078ccd0fb2ce6 SHA512 c3d7c7b2d221b33ad4f4685207ff606d271635bd1ad7edab763a823880386f604d264343139f37b36a3e8654d6382dbed0d431556728676523e390b8fb4b2aef
DIST spdlog-1.0.0.tar.gz 183855 BLAKE2B 30d54fef03a83f968cfebacf95a484ff397126771a7ea022556aebd07e2f7694af35b278f75ee24372283ff1428e21247fd4329794d64a65bd6220a93f21db3c SHA512 4d3cbc1926be513256b5837a53fce425f6d352bb4ab262074f205450cd4eadc09feea9dc8d8c03b3f1e9792bcfbcff414be79e51d58234f540946428bbd88cd1
+DIST spdlog-1.1.0.tar.gz 183937 BLAKE2B 51af49f641df69e78835bd6b9545da53c0e111bab60a5f0dbf4a1d0e70101309394ffea195176ea371f08b772c2be1c22c2da16006fc9699f47593cf82a6c0fd SHA512 65fbe6e9dffb25e814f72f2ef7982eed213fc16edfabb1377f865c94fd0488190e160dfea83ac06979a41f2fb2fa47a454989ebee0a2c5012bd404b977648439
diff --git a/dev-libs/spdlog/spdlog-1.1.0.ebuild b/dev-libs/spdlog/spdlog-1.1.0.ebuild
new file mode 100644
index 000000000000..03aaec9bd608
--- /dev/null
+++ b/dev-libs/spdlog/spdlog-1.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Very fast, header only, C++ logging library"
+HOMEPAGE="https://github.com/gabime/spdlog"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gabime/spdlog"
+else
+ SRC_URI="https://github.com/gabime/spdlog/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0/1"
+IUSE="test"
+
+DEPEND="
+ >=dev-libs/libfmt-5.0.0
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-1.0.0-unbundle-fmt.patch" )
+
+src_configure() {
+ rm -r include/spdlog/fmt/bundled || die
+
+ local mycmakeargs=(
+ -DSPDLOG_BUILD_EXAMPLES=no
+ -DSPDLOG_BUILD_TESTING=$(usex test)
+ )
+
+ cmake-utils_src_configure
+}