summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2016-05-13 19:47:23 +0200
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2016-05-13 19:47:23 +0200
commit33f49af573127885b5d8ba6ae91c6e97b29fef35 (patch)
treec55bb62c14f4768b73772317ae1b5dec31d711c0 /dev-libs
parentsys-devel/automake: rework --docdir flag for automatic prefix support #582734 (diff)
downloadgentoo-33f49af573127885b5d8ba6ae91c6e97b29fef35.tar.gz
gentoo-33f49af573127885b5d8ba6ae91c6e97b29fef35.tar.bz2
gentoo-33f49af573127885b5d8ba6ae91c6e97b29fef35.zip
dev-libs/libinput: Version bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libinput/Manifest1
-rw-r--r--dev-libs/libinput/libinput-1.3.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-libs/libinput/Manifest b/dev-libs/libinput/Manifest
index 456bfd01e2a4..ddc08c48c980 100644
--- a/dev-libs/libinput/Manifest
+++ b/dev-libs/libinput/Manifest
@@ -3,3 +3,4 @@ DIST libinput-1.1.0.tar.xz 802348 SHA256 673186ea2a0d2b695afaa9758834f9217b17577
DIST libinput-1.1.5.tar.xz 806960 SHA256 5e08c45dbb8bf32490cc6cd626da098564d646d161a07cba2e3adbd9745c0622 SHA512 031663c46b556048224aab018eb8ea76e34aace77508e52e6ef382a452585fafd4c91b427c0892aab3c624c0cfedc15c388922ae7166248e5da65575ff900c31 WHIRLPOOL 760cc1cf0c6657efbdadadd2f50e188d86465e1aa3f287275323d6fad9156b684de0d3b6dbf6e3fd5213018770726087ee282833f25ba5ef67918c0284b885a1
DIST libinput-1.2.2.tar.xz 857176 SHA256 08ac5b3620d86df1cdb4970c4137c8746c9f4b9f0c8e7dfab49858dbceb8f367 SHA512 d738890b7fc34a66cdb6ebb58f28060ffc81dccda56aa144622f62efc054431d75564d11f6d9a96a2c17032f15093ca98db9f087822977cec9fced428efd2f8b WHIRLPOOL 66128be8bc6019a6c8986fa4ea05041fa75da38fc60232e3d1b12e0e4e90c2d049b622cf3cae7b4107cacbacf6139804693695928d1055a5203c664888d59547
DIST libinput-1.2.3.tar.xz 860400 SHA256 09b2a9d3a0cc973a9d3fdc7af40162cbef0b16be0a2e415786f83761f519e9f2 SHA512 2b82169a395c4f8b3d9a6250b1e4787b7dac1a0a7ea421036ccbbfdb256c59f848f68233522db977d311a48abfef28b3c3f0b3779254c34469b84c7287a90fbf WHIRLPOOL ce0517cf824193c56a82a1ac61e5c8950e6f7910162c65b996bc0330e2a1fff53a59494b3f516b412995dc9af59c598b3ae6123ce601b32da07a370540705b86
+DIST libinput-1.3.0.tar.xz 878372 SHA256 998a75fb261d161efaa7da44411cdc9a32a953280e4ffc6322ca19f057d0c1ea SHA512 dbd373d7b359419d059a8e6e31a701ccdf786393f5a5c1d97abc00e52ac167b80e7dcca9f9fe09de34812642898b4e19e6723bb5336c039c31012cc148d966aa WHIRLPOOL 1d2beff56b2d7a2327883e50c8a4dfe83531b1c096bf5ce778c10c09beec6cd104ca6c189318383f541912e2b76e287c2d15dc546527e24aadaa1938291351cb
diff --git a/dev-libs/libinput/libinput-1.3.0.ebuild b/dev-libs/libinput/libinput-1.3.0.ebuild
new file mode 100644
index 000000000000..8ec94bd29692
--- /dev/null
+++ b/dev-libs/libinput/libinput-1.3.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils udev
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libinput/"
+SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/10"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="input_devices_wacom test"
+# Tests require write access to udev rules directory which is a no-no for live system.
+# Other tests are just about logs, exported symbols and autotest of the test library.
+RESTRICT="test"
+
+RDEPEND="
+ input_devices_wacom? ( >=dev-libs/libwacom-0.12 )
+ >=dev-libs/libevdev-0.4
+ >=sys-libs/mtdev-1.1
+ virtual/libudev
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+# test? (
+# >=dev-libs/check-0.9.10
+# dev-util/valgrind
+# sys-libs/libunwind )
+
+src_prepare() {
+ # Doc handling in kinda strange but everything
+ # is available in the tarball already.
+ sed -e 's/^\(SUBDIRS =.*\)doc\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die
+}
+
+src_configure() {
+ # gui can be built but will not be installed
+ # building documentation silently fails with graphviz syntax errors
+ econf \
+ --disable-documentation \
+ --disable-event-gui \
+ $(use_enable input_devices_wacom libwacom) \
+ $(use_enable test tests) \
+ --with-udev-dir="$(get_udevdir)"
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc -r doc/html
+ prune_libtool_files
+}