summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSalah Coronya <salah.coronya@gmail.com>2020-07-21 23:37:22 -0500
committerJoonas Niilola <juippis@gentoo.org>2020-08-05 15:18:40 +0300
commit3bc5a054be3b3620a72849cc2745177d7ca19a92 (patch)
tree496a92e71cc600d14e54ea82c14fedaf17c62050 /dev-libs
parentapp-crypt/swtpm: Remove old (diff)
downloadgentoo-3bc5a054be3b3620a72849cc2745177d7ca19a92.tar.gz
gentoo-3bc5a054be3b3620a72849cc2745177d7ca19a92.tar.bz2
gentoo-3bc5a054be3b3620a72849cc2745177d7ca19a92.zip
dev-libs/libtpms: Bump to 0.7.3
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Salah Coronya <salah.coronya@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libtpms/Manifest1
-rw-r--r--dev-libs/libtpms/libtpms-0.7.3.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/libtpms/Manifest b/dev-libs/libtpms/Manifest
index 1ad68862d4db..7b23c0510c37 100644
--- a/dev-libs/libtpms/Manifest
+++ b/dev-libs/libtpms/Manifest
@@ -1 +1,2 @@
DIST libtpms-0.7.2.tar.gz 1205662 BLAKE2B e549d94b6915b3a126aac76bc65c743acf9295fa4b4b836cfc34fb4cbe52e6da000d11d2995de377ccf5d0e2366d763dd1a881c4f4ab87631c52ad62b3792b7a SHA512 ddc1e00e01fe91977ac78e069a0005b7b6a4e34f41c2d53bfb24f3fdaea73945a83ae5aa344d01b6636fdd2f3dd30c4ec54b1ef58d0964700ba4cf688d436739
+DIST libtpms-0.7.3.tar.gz 1206014 BLAKE2B 32636be3e15e27a53de1c935144d2363a80689456bd70493b4eef38214ef1b9ef84ae43d1da253c9dd3e362d385b6e1638eace7a1f105736ca54f581a5f474f0 SHA512 bfd573f909965991e266434391de5f1e52c724e679e5580b7839032a1ee57f8d36cdec6d892b1d22fb7285335801a6fe17ea8559ea7ba43704fbf57c6a06dd05
diff --git a/dev-libs/libtpms/libtpms-0.7.3.ebuild b/dev-libs/libtpms/libtpms-0.7.3.ebuild
new file mode 100644
index 000000000000..1daf31882dc5
--- /dev/null
+++ b/dev-libs/libtpms/libtpms-0.7.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Library providing software emultion of a TPM"
+HOMEPAGE="https://github.com/stefanberger/libtpms"
+SRC_URI="https://github.com/stefanberger/libtpms/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libressl"
+
+DEPEND=" !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ --with-openssl \
+ --with-tpm2
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}