summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-05-17 16:54:28 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-05-17 16:54:43 +0200
commit42a92b2fe4a3c1eaf117f082af52b08a83b20104 (patch)
tree0a564b87f0e8f819afd228184c0ca5f134ff2e85 /dev-libs
parentvirtual/mysql: Drop old (diff)
downloadgentoo-42a92b2fe4a3c1eaf117f082af52b08a83b20104.tar.gz
gentoo-42a92b2fe4a3c1eaf117f082af52b08a83b20104.tar.bz2
gentoo-42a92b2fe4a3c1eaf117f082af52b08a83b20104.zip
dev-libs/librelp: Don't enable valgrind in tests
Closes: https://bugs.gentoo.org/655952 Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/librelp/files/librelp-1.2.16-fix-valgrind-usage.patch27
-rw-r--r--dev-libs/librelp/librelp-1.2.16.ebuild2
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/librelp/files/librelp-1.2.16-fix-valgrind-usage.patch b/dev-libs/librelp/files/librelp-1.2.16-fix-valgrind-usage.patch
new file mode 100644
index 000000000000..15f605dd4825
--- /dev/null
+++ b/dev-libs/librelp/files/librelp-1.2.16-fix-valgrind-usage.patch
@@ -0,0 +1,27 @@
+Upstream bug: https://github.com/rsyslog/librelp/issues/100
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -176,16 +176,20 @@ fi
+
+ # valgrind
+ AC_ARG_ENABLE(valgrind,
+- [AS_HELP_STRING([--enable-valgrind],[Enable valgrind tests@<:@default=yes@:>@])],
++ [AS_HELP_STRING([--enable-valgrind],[Enable valgrind tests@<:@default=no@:>@])],
+ [case "${enableval}" in
+ yes) enable_valgrind="yes" ;;
+ no) enable_valgrind="no" ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-valgrind) ;;
+ esac],
+- [enable_valgrind="yes"]
++ [enable_valgrind="no"]
+ )
+ if test "$enable_valgrind" = "yes"; then
+ AC_CHECK_PROG(VALGRIND, [valgrind], [valgrind], [no])
++
++ if test "x$VALGRIND" = "xno"; then
++ AC_MSG_ERROR([valgrind is missing but forced with --enable-valgrind. Either install valgrind or remove the option!])
++ fi
+ fi
+ AM_CONDITIONAL([HAVE_VALGRIND], test "$enable_valgrind" == "yes")
+
diff --git a/dev-libs/librelp/librelp-1.2.16.ebuild b/dev-libs/librelp/librelp-1.2.16.ebuild
index e82777d8801b..62f7452fb6a6 100644
--- a/dev-libs/librelp/librelp-1.2.16.ebuild
+++ b/dev-libs/librelp/librelp-1.2.16.ebuild
@@ -26,6 +26,8 @@ DEPEND="
virtual/pkgconfig
"
+PATCHES=( "${FILESDIR}"/${P}-fix-valgrind-usage.patch )
+
src_prepare() {
sed -i \
-e 's/ -g"/"/g' \