summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-05-06 08:46:23 -0700
committerMatt Turner <mattst88@gentoo.org>2021-05-06 08:48:13 -0700
commit45083fc71193d4d1d9e5a31f4b06a6204ebf88bf (patch)
treef5b46e5d2db951084635910676fe08d9ca358030 /dev-libs
parentdev-python/regex: stable 2021.4.4 for hppa, bug #788535 (diff)
downloadgentoo-45083fc71193d4d1d9e5a31f4b06a6204ebf88bf.tar.gz
gentoo-45083fc71193d4d1d9e5a31f4b06a6204ebf88bf.tar.bz2
gentoo-45083fc71193d4d1d9e5a31f4b06a6204ebf88bf.zip
dev-libs/gjs: Version bump to 1.68.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/gjs/Manifest1
-rw-r--r--dev-libs/gjs/gjs-1.68.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-libs/gjs/Manifest b/dev-libs/gjs/Manifest
index 52f990208bc2..4897f767a8f5 100644
--- a/dev-libs/gjs/Manifest
+++ b/dev-libs/gjs/Manifest
@@ -1,3 +1,4 @@
DIST gjs-1.64.4.tar.xz 422496 BLAKE2B a96211f7240336dbb30c6965e405f59ee72e4288842837da8da8c6d3c59b7e04ebb6c7a8b0b02d38601c162ffdf1a1fef9f13e4db720c4c483f4a39dffd5dbb4 SHA512 21a15d7106ad6584fb1f02cb0a0a4cab211a3540adb8f2c03d35c211e3946b81935000a52351fedd95a18a7ff6b7f96e665fcafa3c411ff79f2b6cb332c82b42
DIST gjs-1.66.2.tar.xz 440184 BLAKE2B 8df23470c763d65733c6fb622a1de8b8fed3e16c1ba67883b6ae0e7150a5a30a334735be39f9c68217501b7674fee8bfce6ab704c0742ae639a1bc14cdce4cd8 SHA512 2e0ca24532b3203a55089eb25de19b4b4f33166f40d1231198947057e45f364d3c7f794ff2079c1d9aee3fde9f99cd844944229d89d5e344a97254aaa42bad40
DIST gjs-1.68.0.tar.xz 553044 BLAKE2B 6103299bb9ec67589393b0a863219b1bb08ebf141229574f07bb4984a2fb226f4daf4324038e9143f98048d0a2997805b93f7f408bae5ef727435c787e3b98f0 SHA512 65278ca345f2c786995bed7755dd86403b469eb6cceaa6db57dbd4af212025a3b1f01b7387f45dc9abc23d47ba2f39c5ab8a90ec95b1934f1471a68a06f0d82d
+DIST gjs-1.68.1.tar.xz 558920 BLAKE2B f5364fe92ddf4cb1e9b5dac5921fa180ed31bfe54ba8ad737e31c5f8a7f19d7e47bad07d7ca088e6e5962b2782a774b985b607214a7381a8b6c54e799df97235 SHA512 bce2f84e748dd483e0c907e7f7f230257aa4b216b76e89c3457ebba5e9bf601dcb5c771ebe864df22255e221876c6e7ee3097328e6f52ef78360f49708ff457a
diff --git a/dev-libs/gjs/gjs-1.68.1.ebuild b/dev-libs/gjs/gjs-1.68.1.ebuild
new file mode 100644
index 000000000000..69f56003cd50
--- /dev/null
+++ b/dev-libs/gjs/gjs-1.68.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org meson virtualx
+
+DESCRIPTION="Javascript bindings for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Projects/Gjs"
+
+LICENSE="MIT || ( MPL-1.1 LGPL-2+ GPL-2+ )"
+SLOT="0"
+IUSE="+cairo examples gtk readline sysprof test"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.66.0
+ dev-libs/libffi:=
+ >=dev-libs/gobject-introspection-1.66.1:=
+ dev-lang/spidermonkey:78
+ cairo? ( x11-libs/cairo[X,svg] )
+ readline? ( sys-libs/readline:0= )
+"
+DEPEND="${RDEPEND}
+ sysprof? ( >=dev-util/sysprof-capture-3.38.1:4 )
+ test? ( sys-apps/dbus
+ >=x11-libs/gtk+-3.20:3[introspection] )
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # FIXME: add systemtap/dtrace support, like in glib:2
+ local emesonargs=(
+ $(meson_feature cairo)
+ $(meson_feature readline)
+ $(meson_feature sysprof profiler)
+ -Dinstalled_tests=false
+ $(meson_use !test skip_dbus_tests)
+ $(meson_use !test skip_gtk_tests)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}