summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2021-12-13 12:14:49 -0500
committerCraig Andrews <candrews@gentoo.org>2021-12-13 12:22:25 -0500
commit65eb166661ad1513dc8824985d2714da2e589f68 (patch)
tree4f5feba7809c1b895c95a4ae015ca360d2a175c0 /dev-libs
parentnet-proxy/privoxy: update to 3.0.33 (diff)
downloadgentoo-65eb166661ad1513dc8824985d2714da2e589f68.tar.gz
gentoo-65eb166661ad1513dc8824985d2714da2e589f68.tar.bz2
gentoo-65eb166661ad1513dc8824985d2714da2e589f68.zip
dev-libs/rapidjson: Only set VALGRIND_EXECUTABLE if use test
Closes: https://bugs.gentoo.org/828771 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/rapidjson/rapidjson-1.1.0-r3.ebuild2
-rw-r--r--dev-libs/rapidjson/rapidjson-9999.ebuild4
2 files changed, 5 insertions, 1 deletions
diff --git a/dev-libs/rapidjson/rapidjson-1.1.0-r3.ebuild b/dev-libs/rapidjson/rapidjson-1.1.0-r3.ebuild
index ac4033ac66cf..da68858dfa4f 100644
--- a/dev-libs/rapidjson/rapidjson-1.1.0-r3.ebuild
+++ b/dev-libs/rapidjson/rapidjson-1.1.0-r3.ebuild
@@ -48,6 +48,8 @@ src_configure() {
-DRAPIDJSON_BUILD_EXAMPLES=$(usex examples)
-DRAPIDJSON_BUILD_TESTS=$(usex test)
-DRAPIDJSON_BUILD_THIRDPARTY_GTEST=OFF
+ )
+ use test && mycmakeargs+=(
-DVALGRIND_EXECUTABLE=
)
cmake_src_configure
diff --git a/dev-libs/rapidjson/rapidjson-9999.ebuild b/dev-libs/rapidjson/rapidjson-9999.ebuild
index 081c33172b8d..c13c44dc56c8 100644
--- a/dev-libs/rapidjson/rapidjson-9999.ebuild
+++ b/dev-libs/rapidjson/rapidjson-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -49,6 +49,8 @@ src_configure() {
-DRAPIDJSON_BUILD_EXAMPLES=$(usex examples)
-DRAPIDJSON_BUILD_TESTS=$(usex test)
-DRAPIDJSON_BUILD_THIRDPARTY_GTEST=OFF
+ )
+ use test && mycmakeargs+=(
-DVALGRIND_EXECUTABLE=
)
cmake_src_configure