summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-08-02 16:43:48 +0200
committerJeroen Roovers <jer@gentoo.org>2020-08-02 17:06:55 +0200
commit69148bea9bf3a7877ae74e2662b47e47b151f5d0 (patch)
tree17b901068cecdddd914a09085f4d1b4a54527478 /dev-libs
parentdev-util/dwarves: Remove old (py2.7) (diff)
downloadgentoo-69148bea9bf3a7877ae74e2662b47e47b151f5d0.tar.gz
gentoo-69148bea9bf3a7877ae74e2662b47e47b151f5d0.tar.bz2
gentoo-69148bea9bf3a7877ae74e2662b47e47b151f5d0.zip
dev-libs/libdnet: Add live ebuild
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libdnet/libdnet-9999.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/dev-libs/libdnet/libdnet-9999.ebuild b/dev-libs/libdnet/libdnet-9999.ebuild
new file mode 100644
index 000000000000..3878f74646eb
--- /dev/null
+++ b/dev-libs/libdnet/libdnet-9999.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+AT_M4DIR="config"
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_OPTIONAL=1
+inherit autotools distutils-r1 git-r3
+
+DESCRIPTION="simplified, portable interface to several low-level networking routines"
+HOMEPAGE="https://github.com/ofalk/libdnet"
+EGIT_REPO_URI="https://github.com/ofalk/libdnet"
+LICENSE="LGPL-2"
+
+SLOT="0"
+KEYWORDS=""
+IUSE="python static-libs test"
+
+DEPEND="
+ python? ( ${PYTHON_DEPS} )
+"
+RDEPEND="
+ ${DEPEND}
+"
+RESTRICT="test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+DOCS=( README.md THANKS TODO )
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's/libcheck.a/libcheck.so/g' \
+ -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' \
+ configure.ac || die
+ sed -i \
+ -e 's|-L$libdir ||g' \
+ dnet-config.in || die
+ sed -i \
+ -e '/^SUBDIRS/s|python||g' \
+ Makefile.am || die
+
+ eautoreconf
+
+ if use python; then
+ cd python
+ distutils-r1_src_prepare
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_with python) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ default
+ if use python; then
+ cd python
+ distutils-r1_src_compile
+ fi
+}
+
+src_install() {
+ default
+ if use python; then
+ cd python
+ unset DOCS
+ distutils-r1_src_install
+ fi
+ find "${D}" -name '*.la' -delete || die
+}