summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-02 06:13:40 +0100
committerSam James <sam@gentoo.org>2021-04-03 16:54:27 +0100
commit709a73ff0229e33cbeacbe37dea808ae336abb90 (patch)
tree481e766374e5ef100a4865f7cce7fe115180c503 /dev-libs
parentdev-libs/libvformat: port to EAPI 7, eutils--, ltprune-- (diff)
downloadgentoo-709a73ff0229e33cbeacbe37dea808ae336abb90.tar.gz
gentoo-709a73ff0229e33cbeacbe37dea808ae336abb90.tar.bz2
gentoo-709a73ff0229e33cbeacbe37dea808ae336abb90.zip
dev-libs/libxdg-basedir: EAPI 7, eutils--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libxdg-basedir/libxdg-basedir-1.2.0-r1.ebuild26
1 files changed, 15 insertions, 11 deletions
diff --git a/dev-libs/libxdg-basedir/libxdg-basedir-1.2.0-r1.ebuild b/dev-libs/libxdg-basedir/libxdg-basedir-1.2.0-r1.ebuild
index 025e69060d40..8c306a31e412 100644
--- a/dev-libs/libxdg-basedir/libxdg-basedir-1.2.0-r1.ebuild
+++ b/dev-libs/libxdg-basedir/libxdg-basedir-1.2.0-r1.ebuild
@@ -1,32 +1,35 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit autotools eutils
+EAPI=7
+
+inherit autotools
DESCRIPTION="Small library to access XDG Base Directories Specification paths"
HOMEPAGE="https://github.com/devnev/libxdg-basedir"
SRC_URI="https://github.com/devnev/libxdg-basedir/archive/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 x86 ~amd64-linux ~x64-macos ~x86-solaris"
-IUSE="doc static-libs"
+IUSE="doc"
-RDEPEND=""
-DEPEND="doc? ( app-doc/doxygen )"
+BDEPEND="doc? ( app-doc/doxygen )"
-S="${WORKDIR}/${PN}-${P}"
+PATCHES=(
+ "${FILESDIR}"/${P}-buffer-overflow.patch
+)
src_prepare() {
- epatch "${FILESDIR}/${P}-buffer-overflow.patch"
+ default
eautoreconf
}
src_configure() {
econf \
- $(use_enable static-libs static) \
+ --disable-static \
$(use_enable doc doxygen-html)
}
@@ -42,8 +45,9 @@ src_install() {
emake DESTDIR="${D}" install
if use doc; then
- dohtml -r doc/html/*
+ docinto html
+ dodoc -r doc/html/*
fi
- find "${D}" -type f -name '*.la' -delete
+ find "${ED}" -type f -name '*.la' -delete
}