summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2020-06-16 23:02:42 +0900
committerAkinori Hattori <hattya@gentoo.org>2020-06-16 23:11:39 +0900
commit711155ec8b347758d52f5c6829218e8351516961 (patch)
treecca08c6d90de00b089a381afe071da0896b7ea2d /dev-libs
parentwww-client/chromium: stable channel bump to 83.0.4103.106 (diff)
downloadgentoo-711155ec8b347758d52f5c6829218e8351516961.tar.gz
gentoo-711155ec8b347758d52f5c6829218e8351516961.tar.bz2
gentoo-711155ec8b347758d52f5c6829218e8351516961.zip
dev-libs/libmoe: update patches
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libmoe/files/libmoe-1.5.8-gentoo.patch9
-rw-r--r--dev-libs/libmoe/files/libmoe-gcc-5.patch (renamed from dev-libs/libmoe/files/libmoe-1.5.8-gcc5.patch)0
-rw-r--r--dev-libs/libmoe/files/libmoe-gentoo.patch (renamed from dev-libs/libmoe/files/libmoe-1.5.8-makefile.patch)28
-rw-r--r--dev-libs/libmoe/libmoe-1.5.8-r3.ebuild9
4 files changed, 25 insertions, 21 deletions
diff --git a/dev-libs/libmoe/files/libmoe-1.5.8-gentoo.patch b/dev-libs/libmoe/files/libmoe-1.5.8-gentoo.patch
deleted file mode 100644
index cf436c11577b..000000000000
--- a/dev-libs/libmoe/files/libmoe-1.5.8-gentoo.patch
+++ /dev/null
@@ -1,9 +0,0 @@
-diff -Naur libmoe-1.5.8.orig/altmalloc.c libmoe-1.5.8/altmalloc.c
---- libmoe-1.5.8.orig/altmalloc.c 2002-02-01 22:25:10.000000000 +0900
-+++ libmoe-1.5.8/altmalloc.c 2008-11-19 08:44:34.000000000 +0900
-@@ -1,3 +1,5 @@
-+#include <string.h>
-+
- #include "altmalloc.h"
-
- alt_allocater_t alt_malloc = malloc;
diff --git a/dev-libs/libmoe/files/libmoe-1.5.8-gcc5.patch b/dev-libs/libmoe/files/libmoe-gcc-5.patch
index a990a37fe240..a990a37fe240 100644
--- a/dev-libs/libmoe/files/libmoe-1.5.8-gcc5.patch
+++ b/dev-libs/libmoe/files/libmoe-gcc-5.patch
diff --git a/dev-libs/libmoe/files/libmoe-1.5.8-makefile.patch b/dev-libs/libmoe/files/libmoe-gentoo.patch
index 2cdfa1a24c22..c4a754bd2aa8 100644
--- a/dev-libs/libmoe/files/libmoe-1.5.8-makefile.patch
+++ b/dev-libs/libmoe/files/libmoe-gentoo.patch
@@ -1,18 +1,26 @@
-diff --git a/Makefile b/Makefile
-index 1bae380..605d674 100644
--- a/Makefile
+++ b/Makefile
-@@ -72,8 +72,7 @@ AR=ar
+@@ -52,8 +52,8 @@
+ INSTBIN=mbconv${EXT}
+
+ DEBUG=
+-CF=${DEBUG} -O2 -Wall -fpic -I.
+-LF=-shared -Wl,-soname,${DEST}.so.${VER}.${RELEASE}
++CF=${DEBUG} -O2 -Wall -fpic -I. ${CFLAGS}
++LF=-shared -Wl,-soname,${DEST}.so.${VER}.${RELEASE} ${LDFLAGS}
+ CC=gcc
+ CPP=gcc -E
+ LD=gcc
+@@ -72,7 +72,7 @@
all: ${INSTLIBA} mbconv mbconv.man
mbconv: mbconv.c ${ALL}
- ${CC} ${CF} -o $@ $< -L. -lmoe
--
+ ${CC} ${CF} ${LDFLAGS} -o $@ $< -L. -lmoe
+
${DEST}.so: ${DEST}.so.${VER}.${RELEASE}
- ln -sf $< $@
-@@ -116,7 +115,7 @@ ${BTRI_Cs}: %.c: %.mk_btri.c mk_btri
+@@ -116,7 +116,7 @@
./mk_btri <$< >$@-new && mv $@-new $@
mk_btri: btri.c btri.h altmalloc.o
@@ -21,3 +29,11 @@ index 1bae380..605d674 100644
mbconv.man: mbconv.pod
pod2man --section=${MANSECT} --center=' ' $< >$@
+--- a/altmalloc.c
++++ b/altmalloc.c
+@@ -1,3 +1,5 @@
++#include <string.h>
++
+ #include "altmalloc.h"
+
+ alt_allocater_t alt_malloc = malloc;
diff --git a/dev-libs/libmoe/libmoe-1.5.8-r3.ebuild b/dev-libs/libmoe/libmoe-1.5.8-r3.ebuild
index 01e7722e7012..41ed7a8019e9 100644
--- a/dev-libs/libmoe/libmoe-1.5.8-r3.ebuild
+++ b/dev-libs/libmoe/libmoe-1.5.8-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -19,9 +19,8 @@ DEPEND="${RDEPEND}"
HTML_DOCS=( libmoe.shtml )
PATCHES=(
- "${FILESDIR}/${P}-gentoo.patch"
- "${FILESDIR}/${P}-makefile.patch"
- "${FILESDIR}/${P}-gcc5.patch" # taken from Debian
+ "${FILESDIR}/${PN}-gentoo.patch"
+ "${FILESDIR}/${PN}-gcc-5.patch" # taken from Debian
)
src_prepare() {
@@ -31,8 +30,6 @@ src_prepare() {
-e "/^PREFIX=/s:=.*:=${EPREFIX}/usr:" \
-e "/^LIBSODIR=/s:=.*:=\$\{PREFIX}/$(get_libdir):" \
-e "/^MANDIR=/s:=.*:=\$\{PREFIX}/share/man:" \
- -e "/^CF=/s:=:=${CFLAGS} :" \
- -e "/^LF=/s:=:=${LDFLAGS} :" \
-e "s:=gcc:=$(tc-getCC):" \
-e "/^AR=/s:=ar:=$(tc-getAR):" \
Makefile || die