summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-03-28 20:08:34 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-03-28 20:10:59 +0200
commit7230d4130ebffbf52a986d6d7bce6716c0309d52 (patch)
treed582b27b4764a07a161ec385f9c67f0e987e600e /dev-libs
parentdev-libs/intel-compute-runtime: add 22.12.22749 (diff)
downloadgentoo-7230d4130ebffbf52a986d6d7bce6716c0309d52.tar.gz
gentoo-7230d4130ebffbf52a986d6d7bce6716c0309d52.tar.bz2
gentoo-7230d4130ebffbf52a986d6d7bce6716c0309d52.zip
dev-libs/intel-compute-runtime: drop 22.11.22682
Closes: https://bugs.gentoo.org/836331 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/intel-compute-runtime/Manifest1
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-22.11.22682.ebuild71
2 files changed, 0 insertions, 72 deletions
diff --git a/dev-libs/intel-compute-runtime/Manifest b/dev-libs/intel-compute-runtime/Manifest
index ff8217dab5a1..7bbeda06fa41 100644
--- a/dev-libs/intel-compute-runtime/Manifest
+++ b/dev-libs/intel-compute-runtime/Manifest
@@ -1,3 +1,2 @@
DIST intel-compute-runtime-21.46.21636.tar.gz 4878855 BLAKE2B 0ada296b36567038b2abeba50c2dae6604981f00cdfc0d5d9d197c793534c887fa1d321ced34b37cf6760bdc9e2b8769cdc24fe3884036b78b983660c90b1ee7 SHA512 a63436d049737b955f0e23bbfc78684f665f3d1a668120e803165839792144154f3f42a52c6533611711592ba6e41408d81196a61e318746b1dae1392d1d29ac
-DIST intel-compute-runtime-22.11.22682.tar.gz 5220769 BLAKE2B c5cacdb0140fe9247353b9922a2e401a866d73ea9d4fa6a4312c984d4ba0751ff60d58f15b49003020d88bef13808113ba8ca84239c140fa7c26edcd401c0d9c SHA512 0e4007b152a20e85d40e71d68144a8dab1be536800650fbd1c3f5e23a0731c733d7dfa943d7ea4e1f19548313b12474bd5b9426ef7f2057a9b106a0fc9a1762a
DIST intel-compute-runtime-22.12.22749.tar.gz 5234659 BLAKE2B 162c4781561a131af51779108817d2a39ea9676e3772a776603c1e7670b03eddd800593a6e9d77d852476b2401582f3ff87c8b9582b5fa0769ab5ec48be6ba70 SHA512 16e4c76a38284d4e1470977845d338dc05195351ac53d63528e93f1990b81d03a8f1a31c53c665fb8e19b5dc9f4ce38ff392ee1158769780de7a7cb83b2b361b
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-22.11.22682.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-22.11.22682.ebuild
deleted file mode 100644
index 1d868e365abd..000000000000
--- a/dev-libs/intel-compute-runtime/intel-compute-runtime-22.11.22682.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-CMAKE_BUILD_TYPE="Release"
-MY_PN="${PN/intel-/}"
-MY_P="${MY_PN}-${PV}"
-
-inherit cmake
-
-DESCRIPTION="Intel Graphics Compute Runtime for oneAPI Level Zero and OpenCL Driver"
-HOMEPAGE="https://github.com/intel/compute-runtime"
-SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="+l0 +vaapi"
-
-RDEPEND="
- dev-libs/libnl:3
- dev-libs/libxml2:2
- >=dev-util/intel-graphics-compiler-1.0.10409
- >=dev-util/intel-graphics-system-controller-0.2.4
- >=media-libs/gmmlib-22.0.2:=
- >=virtual/opencl-3
- l0? ( >=dev-libs/level-zero-1.7.9 )
- vaapi? (
- x11-libs/libdrm[video_cards_intel]
- x11-libs/libva
- )
-"
-
-# for Khronos OpenGL headers
-DEPEND="
- ${RDEPEND}
- media-libs/mesa
-"
-
-BDEPEND="virtual/pkgconfig"
-
-DOCS=( "README.md" "FAQ.md" )
-
-PATCHES=( "${FILESDIR}/${PN}-22.11.22682-metrics.patch" )
-
-src_configure() {
- local mycmakeargs=(
- -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
- -DCMAKE_INSTALL_LIBDIR="$(get_libdir)"
- -DBUILD_WITH_L0="$(usex l0)"
- -DDISABLE_LIBVA="$(usex !vaapi)"
- # -DNEO__METRICS_LIBRARY_INCLUDE_DIR="${ESYSROOT}/usr/include"
- -DKHRONOS_GL_HEADERS_DIR="${ESYSROOT}/usr/include"
- -DOCL_ICD_VENDORDIR="${EPREFIX}/etc/OpenCL/vendors"
- -DSUPPORT_DG1="ON"
-
- # See https://github.com/intel/intel-graphics-compiler/issues/204
- -DNEO_DISABLE_BUILTINS_COMPILATION="ON"
-
- # If enabled, tests are automatically run during
- # the compile phase and we cannot run them because
- # they require permissions to access the hardware.
- -DSKIP_UNIT_TESTS="1"
-
- -Wno-dev
- )
-
- cmake_src_configure
-}