summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-18 05:11:50 +0100
committerSam James <sam@gentoo.org>2021-10-18 05:11:50 +0100
commit75ca7040aaa9a72ddf3beeb0f4771bcefa252c14 (patch)
tree2fc2a83c11d980456101eb3417c518923f5e5de8 /dev-libs
parentdev-libs/libuev: split patch to two (diff)
downloadgentoo-75ca7040aaa9a72ddf3beeb0f4771bcefa252c14.tar.gz
gentoo-75ca7040aaa9a72ddf3beeb0f4771bcefa252c14.tar.bz2
gentoo-75ca7040aaa9a72ddf3beeb0f4771bcefa252c14.zip
dev-libs/libuev: call eautoreconf for patches
Needed for patches to *.am, *.ac, etc to be (safely) effective (avoid maintainer mode invocation). Closes: https://bugs.gentoo.org/806604 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libuev/libuev-2.3.2-r1.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-libs/libuev/libuev-2.3.2-r1.ebuild b/dev-libs/libuev/libuev-2.3.2-r1.ebuild
index 2cd8e6b9f812..f8a20c0605ff 100644
--- a/dev-libs/libuev/libuev-2.3.2-r1.ebuild
+++ b/dev-libs/libuev/libuev-2.3.2-r1.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit autotools
+
DESCRIPTION="Lightweight event loop library for Linux epoll() family APIs"
HOMEPAGE="https://github.com/troglobit/libuev"
SRC_URI="https://github.com/troglobit/${PN}/releases/download/v${PV}/${P}.tar.xz"
@@ -15,7 +17,14 @@ IUSE="static-libs"
PATCHES=(
"${FILESDIR}/${PN}"-fix-tests.patch
"${FILESDIR}/${PN}"-large-files-fix.patch
- )
+)
+
+src_prepare() {
+ default
+
+ # Needed for glibc/LFS patches
+ eautoreconf
+}
src_configure() {
econf --enable-static=$(usex static-libs)